Closed Bug 1532801 Opened 6 months ago Closed 5 months ago

windows/aarch64 - toolkit/mozapps/update/tests/unit_service_updater | shouldRunServiceTest - [shouldRunServiceTest : 2033] the updater.exe binary should not be signed when the test registry key doesn't exist

Categories

(Toolkit :: Application Update, defect, P5)

defect

Tracking

()

RESOLVED FIXED
mozilla68
Tracking Status
firefox68 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: egao)

References

(Depends on 1 open bug, Blocks 1 open bug)

Details

Attachments

(1 file)

#[markdown(off)]
Filed by: egao [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=231977047&repo=try

https://queue.taskcluster.net/v1/task/Xiw_R8wkQOqIfM7CN-12MA/runs/0/artifacts/public/logs/live_backing.log

Test: opt-xpcshell-8

Context:
21:03:34 INFO - TEST-START | toolkit/mozapps/update/tests/unit_service_updater/bootstrapSvc.js
21:03:34 WARNING - TEST-UNEXPECTED-FAIL | toolkit/mozapps/update/tests/unit_service_updater/bootstrapSvc.js | xpcshell return code: 0
21:03:34 INFO - TEST-INFO took 272ms
21:03:34 INFO - >>>>>>>
21:03:34 INFO - PID 2292 | Unable to load \\untrusted-startup-test-dll.dll; LoadLibraryW failed: 126
21:03:34 INFO - (xpcshell/head.js) | test MAIN run_test pending (1)
21:03:34 INFO - "21:03:34:784 | TEST-INFO | xpcshellUtilsAUS.js | [setupTestCommon : 738] start - general test setup"
21:03:34 INFO - TEST-PASS | toolkit/mozapps/update/tests/unit_service_updater/bootstrapSvc.js | setupTestCommon - [setupTestCommon : 740] gTestID should be 'undefined' (setupTestCommon should only be called once) - "undefined" === "undefined"
21:03:34 INFO - TEST-PASS | toolkit/mozapps/update/tests/unit_service_updater/bootstrapSvc.js | shouldRunServiceTest - [shouldRunServiceTest : 2011] the file or directory should exist, leafName: updater.exe - true == true
21:03:34 INFO - "21:03:34:787 | TEST-INFO | xpcshellUtilsAUS.js | [runTestHelperSync : 1842] Running C:\\tasks\\task_1551817728\\build\\tests\\xpcshell\\tests\\toolkit\\mozapps\\update\\tests\\data\\TestAUSHelper.exe check-signature C:\\tasks\\task_1551817728\\build\\application\\firefox\\updater.exe"
21:03:34 WARNING - TEST-UNEXPECTED-FAIL | toolkit/mozapps/update/tests/unit_service_updater/bootstrapSvc.js | shouldRunServiceTest - [shouldRunServiceTest : 2033] the updater.exe binary should not be signed when the test registry key doesn't exist (if it is, build system configuration bug?) - false == true
21:03:34 INFO - xpcshellUtilsAUS.js:shouldRunServiceTest:2033
21:03:34 INFO - xpcshellUtilsAUS.js:setupTestCommon:764
21:03:34 INFO - C:/tasks/task_1551817728/build/tests/xpcshell/tests/toolkit/mozapps/update/tests/unit_service_updater/bootstrapSvc.js:run_test:8
21:03:34 INFO - C:\tasks\task_1551817728\build\tests\xpcshell\head.js:_execute_test:520
21:03:34 INFO - -e:null:1
21:03:34 INFO - exiting test
21:03:34 INFO - (xpcshell/head.js) | test MAIN run_test finished (1)
21:03:34 INFO - exiting test
21:03:34 WARNING - TEST-UNEXPECTED-FAIL | toolkit/mozapps/update/tests/unit_service_updater/bootstrapSvc.js | assertNoUncaughtRejections - [assertNoUncaughtRejections : 257] A promise chain failed to handle a rejection: [Exception... "Abort" nsresult: "0x80004004 (NS_ERROR_ABORT)" location: "JS frame :: C:\\tasks\\task_1551817728\\build\\tests\\xpcshell\\head.js :: _abort_failed_test :: line 739" data: no] - stack: _abort_failed_test@C:\\tasks\\task_1551817728\\build\\tests\\xpcshell\\head.js:739:20
21:03:34 INFO - do_report_result@C:\\tasks\\task_1551817728\\build\\tests\\xpcshell\\head.js:846:5
21:03:34 INFO - Assert<@C:\\tasks\\task_1551817728\\build\\tests\\xpcshell\\head.js:54:5
21:03:34 INFO - proto.report@resource://testing-common/Assert.jsm:213:10
21:03:34 INFO - proto.ok@resource://testing-common/Assert.jsm:233:10
21:03:34 INFO - shouldRunServiceTest@xpcshellUtilsAUS.js:2033:14
21:03:34 INFO - setupTestCommon@xpcshellUtilsAUS.js:764:26
21:03:34 INFO - run_test@C:/tasks/task_1551817728/build/tests/xpcshell/tests/toolkit/mozapps/update/tests/unit_service_updater/bootstrapSvc.js:8:8
21:03:34 INFO - _execute_test@C:\\tasks\\task_1551817728\\build\\tests\\xpcshell\\head.js:520:7
21:03:34 INFO - @-e:1:1
21:03:34 INFO - Rejection date: Tue Mar 05 2019 21:03:34 GMT+0000 (Greenwich Mean Time) - false == true
21:03:34 INFO - resource://testing-common/PromiseTestUtils.jsm:assertNoUncaughtRejections:257
21:03:34 INFO - C:\tasks\task_1551817728\build\tests\xpcshell\head.js:_execute_test:618
21:03:34 INFO - -e:null:1
21:03:34 INFO - exiting test
21:03:34 INFO - PID 2292 | JavaScript error: C:\\tasks\\task_1551817728\\build\\tests\\xpcshell\\head.js, line 739: NS_ERROR_ABORT:
21:03:34 INFO - PID 2292 | JavaScript error: C:\\tasks\\task_1551817728\\build\\tests\\xpcshell\\head.js, line 739: NS_ERROR_ABORT
21:03:34 INFO - <<<<<<<

Keywords: regression

:rstrong, are you aware of any caveats around the application update feature in windows10-aarch64 build? If you are not the right person to look, could you redirect the ni to the correct person? Thanks!

Flags: needinfo?(robert.strong.bugs)
Summary: windows/aarch64 - toolkit/mozapps/update/tests/unit_service_updater/bootstrapSvc.js | multiple failures → windows/aarch64 - toolkit/mozapps/update/tests/unit_service_updater | shouldRunServiceTest - [shouldRunServiceTest : 2033] the updater.exe binary should not be signed when the test registry key doesn't exist
Duplicate of this bug: 1532804

Updated summary to reflect that this failure string is a common failure that occurs across xpcshell-8.

TEST-UNEXPECTED-FAIL | toolkit/mozapps/update/tests/unit_service_updater/bootstrapSvc.js | shouldRunServiceTest - [shouldRunServiceTest : 2033] the updater.exe binary should not be signed when the test registry key doesn't exist (if it is, build system configuration bug?) - false == true

This is due to bug 1526982

Depends on: 1526982
Flags: needinfo?(robert.strong.bugs)
Pushed by egao@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5eea15162109
disable updater related tests as it is not ready r=jmaher
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
You need to log in before you can comment on or make changes to this bug.