Update Windows Rust to 1.34 beta

RESOLVED FIXED in Firefox 68

Status

enhancement
RESOLVED FIXED
3 months ago
2 months ago

People

(Reporter: dmajor, Assigned: dmajor)

Tracking

(Blocks 2 bugs)

Trunk
mozilla68
Dependency tree / graph

Firefox Tracking Flags

(firefox68 fixed)

Details

Attachments

(1 attachment)

Assignee

Description

3 months ago

We need this for cross-language LTO (bug 1486042) in order to pick up https://github.com/rust-lang/rust/pull/58057.

Initially we'll only care about this on Win64. I have no preference on whether to switch the Rust on all platforms or just Windows.

I believe this will also fix the ARM64 issues in bug 1531986 and related.

This still needs the SIMD fixes from bug 1521249.

I am told that we're OK to use a beta rust on nightly because it will be stable by the time we ship our stable (we'd pick up the stable release on our beta). If this is not correct, please let me know.

This transitively depends on bug 1521734 as discussed with dmajor on IRC, but mentioning it explicitly for other readers. (That is, bug 1521734 is the reason bug 1521249 hasn't landed despite having reviewed patches.)

Assignee

Updated

2 months ago
Blocks: rustup
Assignee

Updated

2 months ago
Summary: Update Rust to 1.34 beta → Update Windows Rust to 1.34 beta
Assignee

Comment 2

2 months ago

This is needed for cross-language LTO (bug 1512723). We don't want to block on waiting for 1.34's release, so we'll get a head start now, but we'll update to the final 1.34 release when available.

Comment 3

2 months ago
Pushed by dmajor@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e3809f2c3cb2
Update Windows Rust to 1.34 beta r=glandium

Comment 4

2 months ago
bugherder
Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
Assignee: nobody → dmajor
Assignee

Updated

2 months ago
Duplicate of this bug: 1531986
Assignee

Updated

2 months ago
Blocks: 1530448
Assignee

Updated

2 months ago
Blocks: 1541447
You need to log in before you can comment on or make changes to this bug.