Remove gfxWindowsPlatform::RecordStartupTelemetry from the content process

RESOLVED FIXED in Firefox 67

Status

()

enhancement
P3
normal
RESOLVED FIXED
3 months ago
2 months ago

People

(Reporter: jimm, Assigned: jewilde)

Tracking

(Blocks 1 bug, {perf})

Trunk
mozilla67
Unspecified
Windows
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox67 fixed)

Details

(Whiteboard: [gfx-noted])

Attachments

(1 attachment)

Reporter

Description

3 months ago

Calls:

NtUserGetProcessUIContextInformation, NtGdiDdDDIEnumAdapters2, NtGdiDdDDICacheHybridQueryValue

Typical stack:

24 - win32u!NtUserDisplayConfigGetDeviceInfo
win32u!NtUserDisplayConfigGetDeviceInfo
user32!DisplayConfigGetDeviceInfo+0xa
dxgi!SAdapterDesc::SAdapterDesc+0x221
dxgi!CDXGIFactory::SampleAdaptersWorker+0x1dc
dxgi!CDXGIFactory::SampleAdapters+0xcd
dxgi!CDXGIFactory::Initialize+0xbb
dxgi!CreateDXGIFactoryImpl+0x72
dxgi!CreateDXGIFactoryActualImpl1+0x32
dxgi!CreateDXGIFactory1+0x5d
xul!mozilla::gfx::DeviceManagerDx::GetDXGIAdapter+0x157
xul!mozilla::gfx::DeviceManagerDx::EnumerateOutputs+0x41
xul!gfxWindowsPlatform::RecordStartupTelemetry+0x37

Keywords: perf
OS: Unspecified → Windows
Priority: -- → P3
Whiteboard: [gfx-noted]
Assignee

Updated

3 months ago
Assignee: nobody → jewilde
Status: NEW → ASSIGNED
Assignee

Comment 1

2 months ago

Adds early exit if not originating in the parent process when recording
display HDR capability. This helps to remove more win32k usage from
content processes.

Assignee

Comment 2

2 months ago

I tagged you for review since you were the last reviewer for this function, but wanted to also double check that restricting this to the main process (which I think is what was intended in Bug 1514840) wouldn't mess up y'all's telemetry pipeline.

Let me know if this works or if you need me to change anything!

Flags: needinfo?(jmuizelaar)
Assignee

Updated

2 months ago
Flags: needinfo?(jmuizelaar)
Keywords: checkin-needed

Comment 3

2 months ago

Pushed by apavel@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/24870321bdeb
restrict gfxWindowsPlatform::RecordStartupTelemetry to parent; r=jrmuizel

Keywords: checkin-needed

Comment 4

2 months ago
bugherder
Status: ASSIGNED → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
You need to log in before you can comment on or make changes to this bug.