Closed Bug 1533260 Opened 1 year ago Closed 1 year ago

Perma tier2 devtools/client/webreplay/mochitest/browser_dbg_rr_logpoint-02.js | Test timed out -

Categories

(Core Graveyard :: Web Replay, defect, P5)

defect

Tracking

(firefox-esr60 unaffected, firefox65 unaffected, firefox66 unaffected, firefox67 fixed)

RESOLVED FIXED
mozilla67
Tracking Status
firefox-esr60 --- unaffected
firefox65 --- unaffected
firefox66 --- unaffected
firefox67 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: bhackett1024)

References

Details

(Keywords: intermittent-failure, regression)

#[markdown(off)]
Filed by: rmaries [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=232359683&repo=mozilla-inbound

https://queue.taskcluster.net/v1/task/F0KOUbyDSHO2JB-lr32d2w/runs/0/artifacts/public/logs/live_backing.log

06:01:56 INFO - TEST-START | devtools/client/webreplay/mochitest/browser_dbg_rr_logpoint-02.js

06:02:41 INFO - TEST-UNEXPECTED-FAIL | devtools/client/webreplay/mochitest/browser_dbg_rr_logpoint-02.js | Test timed out -
06:02:41 INFO - GECKO(1977) | console.warn: "Error while detaching the thread front: 'detach' request packet to 'server1.conn8.child1/context22' can't be sent as the connection is closed."
06:02:41 INFO - Removing tab.
06:02:41 INFO - Waiting for event: 'TabClose' on [object XULElement].
06:02:41 INFO - Got event: 'TabClose' on [object XULElement].
06:02:42 INFO - Tab removed and finished closing
06:02:42 INFO - GECKO(1977) | MEMORY STAT | vsize 4416MB | residentFast 493MB | heapAllocated 152MB
06:02:42 INFO - TEST-OK | devtools/client/webreplay/mochitest/browser_dbg_rr_logpoint-02.js | took 45741ms
06:02:42 INFO - checking window state

Summary: Intermittent devtools/client/webreplay/mochitest/browser_dbg_rr_logpoint-02.js | Test timed out - → Perma tier2 devtools/client/webreplay/mochitest/browser_dbg_rr_logpoint-02.js | Test timed out -

It seems to be started here: Bug 1530133 https://hg.mozilla.org/mozilla-central/rev/033697893400
Brian, can you take a look?

Flags: needinfo?(bhackett1024)

Hmm, this test has been passing consistently in the try runs I've done, e.g.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=b083d859cab15d3c2ca7cd5eeb4d1a60f38f331a&selectedJob=232309486

Is this permanently failing on inbound, or is it intermittent?

This is a perma failing. It is also occurring on mozilla-central.

OK, thanks. Looking at treeherder it looks like the failures started with the merge from m-c last night, rather than bug 1530133. I think this is fallout from bug 1531350, and I'll push a fix for the test soon.

Flags: needinfo?(bhackett1024)
Pushed by bhackett@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/289dadcfedfb
Fix browser_dbg_rr_logpoint-02.js test failures.
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
Assignee: nobody → bhackett1024
See Also: → 1557941
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.