Closed Bug 1533745 Opened 6 months ago Closed 5 months ago

Sync didn't get back my previous Nightly windows and tabs in a new Nightly install

Categories

(Firefox :: Sync, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1215714

People

(Reporter: gaby2300, Unassigned)

Details

Using Windows 7 32 bit and Nightly

STR

  1. Uninstall Nightly.
  2. Install it again.
  3. Sync

Expected result: I should have got back my previous Nightly windows and tabs.

Actual result: I didn't get back my previous Nightly windows and tabs.

Hi Gabriela,

Please in the URL bar go to about:config and look after services.sync.clients.lastSync. You need to see a number, please add the number to this bug report.

Thanks

Flags: needinfo?(gmontagu)

(In reply to ovidiu boca[:Ovidiu] from comment #1)

Thank you so much for commenting so quickly!

The number is: 1552052265.53

Flags: needinfo?(gmontagu)

Can you please verify if other data is sync? History, bookmarks?

What I think happened here is that, after you installed the latest Nightly and you open it, a new tab was open because you don't have the "Restore previous session" option checked from Option -> Startup. You can verify in about:profiles what profile is used, I'm guessing is the default.

You can repeat the steps but before to uninstall the Nightly from step 1 go to Menu -> Options -> and check the "Restore previous session" checkbox.

Flags: needinfo?(gmontagu)

(In reply to ovidiu boca[:Ovidiu] from comment #3)

Can you please verify if other data is sync? History, bookmarks?
Sorry, I don't understand what you mean.

What I think happened here is that, after you installed the latest Nightly and you open it, a new tab was open because you don't have the "Restore previous session" option checked from Option -> Startup.
I did have that that option checked, I always do that. Actually, it's one of the first things I do in new installs!

You can verify in about:profiles what profile is used, I'm guessing is the default.
The actual one is the default because it's a new install.

You can repeat the steps but before to uninstall the Nightly from step 1 go to Menu -> Options -> and check the "Restore previous session" checkbox.
Sorry but why should I do this when I'm sure I have/had the option checked?

Flags: needinfo?(gmontagu)

Hi Gabriela, unfortunately, we don't sync session data like open windows (bug 1215714), so Sync can't restore your previous Nightly windows and tabs automatically.

You can use the Synced Tabs sidebar to restore your synced tabs (right-click the device name and choose "Open All in Tabs"), from either another device or a different profile...but this will open all tabs in the same window.

A few more questions for you:

  1. When you reinstalled Nightly, did you also have to sign in to Firefox Accounts again?
  2. Did you manually delete your profile after uninstalling?
  3. Which profiles do you see in about:profiles?

Thanks!

Flags: needinfo?(gmontagu)

(In reply to Lina Cambridge (she/her) [:lina] from comment #5)

Hi Gabriela, unfortunately, we don't sync session data like open windows (bug 1215714), so Sync can't restore your previous Nightly windows and tabs automatically.
I don't understand what`s the use of Sync in this case then!

You can use the Synced Tabs sidebar to restore your synced tabs (right-click the device name and choose "Open All in Tabs"), from either another device or a different profile...but this will open all tabs in the same window.
I'm afraid I don't understand the difference. Forget windows because I always have only one, but why didn't it sync my opened tabs? And, I do have several profiles, but I didn't know I should have synced form another one. Why isn't this info included in the new per profile installation info?

A few more questions for you:

  1. When you reinstalled Nightly, did you also have to sign in to Firefox Accounts again?
    Yes.
  1. Did you manually delete your profile after uninstalling?
    No, I didn't. If this is necessary, then it should be added to the new per profile installation info!
  1. Which profiles do you see in about:profiles?
    In the new install I see Default

Thanks!

Thank you for your interest in my issue!

Flags: needinfo?(gmontagu)

(In reply to Gabriela [:gaby2300] from comment #6)

(In reply to Lina Cambridge (she/her) [:lina] from comment #5)

  1. When you reinstalled Nightly, did you also have to sign in to Firefox Accounts again?
    Yes.
  1. Did you manually delete your profile after uninstalling?
    No, I didn't. If this is necessary, then it should be added to the new per profile installation info!

It shouldn't be necessary, but what should have happened is that your existing profile information should have remained after uninstalling Nightly, so the new Nightly should have seen it - and that should have restored your tabs.

I suspect it's too late to work out what happened there, but as Lina mentioned, the fact Sync doesn't restore this info is bug 1215714, so I'm going to mark this as a dupe of that.

Please accept our apologies for Firefox letting you down in this case!

Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1215714
You need to log in before you can comment on or make changes to this bug.