Closed Bug 1533764 Opened 8 months ago Closed 7 months ago

Enable column resizer in Nightly

Categories

(DevTools :: Netmonitor, enhancement, P2)

enhancement

Tracking

(firefox67 fixed, firefox68 fixed)

RESOLVED FIXED
Firefox 68
Tracking Status
firefox67 --- fixed
firefox68 --- fixed

People

(Reporter: Honza, Unassigned)

References

Details

Attachments

(1 file)

Support for columns resizing was implemented in bug 1358414 - currently hidden behind a pref: devtools.netmonitor.features.resizeColumns

We should turn the pref on at the beginning of the 68 release cycle.

Honza

Priority: -- → P2
Pushed by jodvarko@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/27e9ef4df5af
enable pref for column resizer in Nightly; r=Honza
Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68

Comment on attachment 9052373 [details]
Bug 1533764 - enable pref for column resizer in Nightly; r=Honza

Beta/Release Uplift Approval Request

  • Feature/Bug causing the regression: None
  • User impact if declined: Network panel doesn't have resizable columns
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): It's been tested in 68 Nightly since the beginning of the cycle and no bug reports reported.
  • String changes made/needed:
Attachment #9052373 - Flags: approval-mozilla-beta?

Comment on attachment 9052373 [details]
Bug 1533764 - enable pref for column resizer in Nightly; r=Honza

We usually don't activate new features in beta but given that this is limited to devtools panels, that QA already tested it in beta 3 (https://bugzilla.mozilla.org/show_bug.cgi?id=1358414#c94), that the code landed during the 67 cycle and that the pref was activated just after the merge to 68 with no reported regression over 4 weeks on Nightly and that this is a highly requested chome-parity feature for our devtools with multiple duplicates to bug 1358414, I am going to take it. Uplift approved for 67 beta 12.

Attachment #9052373 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Thanks!

Honza

Flags: qe-verify-
You need to log in before you can comment on or make changes to this bug.