Closed Bug 1534003 Opened 1 year ago Closed 1 year ago

Update page title in about:buildconfig

Categories

(Firefox :: General, enhancement)

enhancement
Not set

Tracking

()

VERIFIED FIXED
Firefox 68
Tracking Status
firefox67 --- wontfix
firefox68 --- verified

People

(Reporter: suriyaa, Assigned: suriyaa, Mentored)

References

()

Details

(Whiteboard: [bugday-20190327])

Attachments

(2 files)

The about:buildconfig site doesn't have an appropriate page title. This bug is based on bug 1051846.

Fixes also partially bug 1051846.

Status: UNCONFIRMED → NEW
Ever confirmed: true
Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/dc2ae28a117f
Update page title in about:buildconfig r=mconley

Hey yzen, do you know what test_docload_embedded.html is trying to do here, and why this test is failing now? I'm having a hard time piecing it together, and why it'd be sensitive to about:buildconfig changes like this. :/

Flags: needinfo?(mconley) → needinfo?(yzenevich)

(In reply to Mike Conley (:mconley) (:⚙️) from comment #4)

Hey yzen, do you know what test_docload_embedded.html is trying to do here, and why this test is failing now? I'm having a hard time piecing it together, and why it'd be sensitive to about:buildconfig changes like this. :/

Looks like we are hardcoding the expected accessible name for the "about:buildconfig" document (essentially the title). It should be fine to change that to the new title value.

Flags: needinfo?(yzenevich)

(In reply to Mike Conley (:mconley) (:⚙️) from comment #6)

Hey yzen,

Does that mean adding another condition here, like we do for about:license?: https://searchfox.org/mozilla-central/rev/7c20ad925005fbad7b8e08813115f1ec7fa1c248/accessible/tests/mochitest/events/docload/test_docload_embedded.html#43

Ah sorry, I should've pointed you there, indeed. I would suggest changing the signature of the changeIframeSrc function to:

function changeIframeSrc(aIdentifier, aURL, aTitle) {
...
            {
              role: ROLE_DOCUMENT,
              name: aTitle,
            },
...
}

and then calling it in the test as:

      gQueue.push(new changeIframeSrc("iframe", "about:license", "Licenses"));
      gQueue.push(new changeIframeSrc("iframe", "about:buildconfig", "Build Configuration"));

Flags: needinfo?(yzenevich)

Okay, thanks.

Hi suriyaa! I'm afraid your patch bounced because of a test that I didn't know about that seems to rely on about:buildconfig having a title that matches its URL. yzen has given some advice on how to update the test to be less fragile - see comment 7.

Is that enough information for you to modify the patch?

Assignee: nobody → mozilla
Flags: needinfo?(mozilla)

Thanks for the information. I'm working on it.

Flags: needinfo?(mozilla)

Fixes BMO bug 1534003 and phab commit D22848.

Flags: needinfo?(mconley)

Done.

Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/801b729bae25
Update page title in about:buildconfig r=mconley
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68

✅ Commit successfully landed. Thanks.

Flags: needinfo?(mconley)

I have reproduced this bug with Nightly 67.0a1 (2019-03-09) Windows 10, 64 Bit !

This bug's fix is Verified with latest Nightly !

  • Build ID 20190402083512
  • User Agent ::--- Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0
Whiteboard: [bugday-20190327]

Marking VERIFIED FIXED based on comment 15.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.