When throbber is present, closing a window while page is still loading results in crash [@ objc_msgSend]

VERIFIED FIXED in Chimera0.3

Status

Camino Graveyard
Page Layout
--
blocker
VERIFIED FIXED
16 years ago
16 years ago

People

(Reporter: Chris Petersen, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

({crash})

unspecified
Chimera0.3
PowerPC
Mac OS X
crash

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
Build: 2002-06-21-05
Platform: OS X 10.1.5
Expected Result: Window should close with no crash resulting
What I got: Application crashes

Steps to reproduce:

1) Customize toolbar by adding progress throbber (globe).
2) Type a url like cnn.com and press return.
3) Before the page is completely loaded, close it.
4) The application should crash.
(Reporter)

Comment 1

16 years ago
Created attachment 88675 [details]
Stack trace
(Reporter)

Comment 2

16 years ago
Winnie,

Can you reproduce this ?

Comment 3

16 years ago
adding to the blocker list and tossing at beard incase he has a fix
Assignee: saari → beard

Updated

16 years ago
Blocks: 147975

Comment 4

16 years ago
Didn't crash for me with 06-21 build.

Comment 5

16 years ago
WorksForMe using Chimera/20020621. (Shouldn't this just be critical rather than
blocker?)
Keywords: crash
Summary: When throbber is present, closing a window while page is still loading results in crash → When throbber is present, closing a window while page is still loading results in crash [@ objc_msgSend]

Comment 6

16 years ago
I could crash this
(Assignee)

Comment 7

16 years ago
i'll take it
Assignee: beard → pinkerton
Target Milestone: --- → Chimera0.3
(Assignee)

Comment 8

16 years ago
the problem here is that we continue loading the page long after the window goes
away. i can't tell why. conrad might be able to tell what we're not doing when
we shut down the machinery.
Status: NEW → ASSIGNED
(Assignee)

Comment 9

16 years ago
ok, i figured it out. the throbber's timer was holding a strong ref to the
browser window controller (since it was the target) and keeping it alive long
after the window went away, and as a result, not stopping any pageloads in progress.

i'll fix it, should be pretty simple.
(Assignee)

Comment 10

16 years ago
fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
(Reporter)

Comment 11

16 years ago
Verified fixed in 2002-06-25-05 NB.
Status: RESOLVED → VERIFIED

Comment 12

16 years ago
*** Bug 154060 has been marked as a duplicate of this bug. ***

Updated

16 years ago
No longer blocks: 147975
Crash Signature: [@ objc_msgSend]
You need to log in before you can comment on or make changes to this bug.