Closed Bug 1534219 Opened 8 months ago Closed 8 months ago

The blockautoplay icon isn't show again after switching back to http://arcticmonkeys.com/

Categories

(Firefox :: Site Identity, defect, P1)

Desktop
All
defect

Tracking

()

VERIFIED FIXED
Firefox 68
Tracking Status
firefox-esr60 --- unaffected
firefox66 --- wontfix
firefox67 --- verified
firefox68 --- verified

People

(Reporter: dcicas, Assigned: daleharvey)

References

(Blocks 1 open bug)

Details

(Keywords: regression)

Attachments

(2 files)

Attached image doorhanger.gif

Notes
*I created this bug based on discussions from bug 1526355/#block_autoplay slack channel

Affected versions

  • Nightly Fx 67.0a1 BuildID: 20190310214003
    Beta Fx 66.0b14
    Affected platforms
    *Win 10 x64
    Win 7 x32
    Ubuntu 18.04 LTS
    Ubuntu 16.04 LTS
    macOS 10.13

Steps to reproduce
Preconditions:
media.autoplay.default = 1
media.autoplay.enabled.user-gestures-needed = true

Open a new window.
Reach https://www.arcticmonkeys.com/
Check the Site Information panel.
Travel to another open tab.
Go back to the arctic monkeys tab.

Expected result
*The block autoplay icon is displayed.

Actual result
*The block autoplay icon is not displayed after returning to the arctic monkeys website.

Regression range
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=73f92838946aac0aab5760bada1a1e8e2218a3e1&tochange=3f5a132b7e4f7579209ca906f9ec79059e426f26

Additional notes
The Block/Allow options are not displayed when first reaching the Arctic Monkeys website.

Assignee: nobody → dharvey
Priority: -- → P1

ok, really not sure what was up with my build but I can reproduce this now

Ok, so its a race condition, the block autoplay message is received before the page has loaded, the progresslistener reports the page loading as a navigation and clears the permission so the next tine the UI is drawn the icon doesnt show

The fix is simple, trying to make a test for it now

Has Regression Range: --- → yes
Keywords: regression
Pushed by dharvey@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ed8f17a27c82
Only clear globally blocked permission on navigation. r=johannh
Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68

Hi Dale,since 67 is marked as affected, should we consider uplifting this to Beta67? If yes, please nominate a patch for uplift.

Flags: needinfo?(dharvey)

Comment on attachment 9051661 [details]
Bug 1534219 - Only clear globally blocked permission on navigation. r=johannh

Beta/Release Uplift Approval Request

  • Feature/Bug causing the regression: None
  • User impact if declined: Icon will not be shown on some sites that have autoplay media blocked
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: Described in https://bugzilla.mozilla.org/show_bug.cgi?id=1534219#c0
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Small patch with very little chance of regressing
  • String changes made/needed:
Flags: needinfo?(dharvey)
Attachment #9051661 - Flags: approval-mozilla-beta?
Flags: qe-verify?
Flags: qe-verify? → qe-verify+
QA Whiteboard: [qa-triaged]

Comment on attachment 9051661 [details]
Bug 1534219 - Only clear globally blocked permission on navigation. r=johannh

FYI, I'll take this patch in beta once it has been verified by QA on Nightly.

Hello,

I verified that this issue is fixed on Nightly Fx 68.0a1 Build Id:20190407214820 for Windows 10 x64, Ubuntu 18.04 and macOS 10.13.
I can confirm this issue is fixed on Nightly.

Comment on attachment 9051661 [details]
Bug 1534219 - Only clear globally blocked permission on navigation. r=johannh

P1 regression verified by QA on Nightly, uplift approved for 67 beta 10, thanks.

Attachment #9051661 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Hello,

I verified and can confirm that this issue is fixed on Fx 67.0b10 on Windows 10 x64, Ubuntu 18.04 and macOS 10.13.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.