Not able to change desktop background colour more than once in set desktop background dialog

VERIFIED FIXED in Firefox 68

Status

()

defect
P2
normal
VERIFIED FIXED
3 months ago
Last month

People

(Reporter: Kwan, Assigned: baku)

Tracking

(Regression, {regression})

unspecified
Firefox 68
Points:
---

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox65 unaffected, firefox66- wontfix, firefox67- wontfix, firefox68 verified)

Details

Attachments

(1 attachment)

Reporter

Description

3 months ago

20:32.32 INFO: Last good revision: 2ee2f297c4106e017231ed67fba4034d766c942b
20:32.32 INFO: First bad revision: c4bf214bd2e65e460fcd24a6483635c1d5cb4771
20:32.32 INFO: Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=2ee2f297c4106e017231ed67fba4034d766c942b&tochange=c4bf214bd2e65e460fcd24a6483635c1d5cb4771

c4bf214bd2e6 Andrea Marchesini — Bug 1459264 - Allow just 1 FilePicker per event - tests, r=smaug
3c2dc7c0e8c9 Andrea Marchesini — Bug 1459264 - Allow just 1 FilePicker per event, r=smaug
a5ad58077bd8 Andrea Marchesini — Bug 167475 - iframes should load just URLs able to return data, r=smaug

STR:

  1. Right click on an image
  2. Chose "Set As Desktop Background..."
  3. Click the colour picker
  4. Hit select (or platform equiv.) in the colour selection dialog that opens
  5. Click the colour picker again

AR:
Nothing

ER:
Colour selection dialog opens again

[Tracking Requested - why for this release]:
UI regression

Flags: needinfo?(amarchesini)
Assignee

Comment 1

3 months ago

Gijs, can you help me with this? On linux it seems we don't expose this feature.

Flags: needinfo?(amarchesini) → needinfo?(gijskruitbosch+bugs)

Comment 2

3 months ago

(In reply to Andrea Marchesini [:baku] from comment #1)

Gijs, can you help me with this? On linux it seems we don't expose this feature.

I'm not sure I follow. The stretch/tile/colour stuff is hidden only on mac, per this ifdef:

https://searchfox.org/mozilla-central/source/browser/components/shell/content/setDesktopBackground.xul#43-63

I don't know what you mean by "we don't expose this feature". I just checked on my ubuntu VM, and I can see the same dialog I see on Windows, with a color button in the top right corner.

Flags: needinfo?(gijskruitbosch+bugs) → needinfo?(amarchesini)

I can reproduce in Ubuntu 18.10, tracking for 67 as this is a functional regression and I would take a safe uplift.

I probably would not take an uplift on release 66. Seems like someone who wants to do this would have workarounds available, like downloading the image and setting their background from the OS.

Priority: -- → P2
Reporter

Comment 5

3 months ago

(In reply to Liz Henry (:lizzard) (use needinfo) from comment #4)

I probably would not take an uplift on release 66. Seems like someone who wants to do this would have workarounds available, like downloading the image and setting their background from the OS.

They can actually still set it since the popup works once, they just can't change this mind and pick something else (without closing and re-opening the dialog). I was mainly concerned this might indicate a more serious bug in the code for bug 1459264. However I couldn't reproduce with the <input type="color">s in about:preferences, so I'm not sure what makes the dialog special. (The obvious check, of the Principal, seems to indicate it is the expected System Principal)

Assignee

Updated

2 months ago
Assignee: nobody → amarchesini
Flags: needinfo?(amarchesini)

Comment 7

2 months ago
Pushed by amarchesini@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2647a23c02bf
HTMLInputElement should always allow popups for system principal, r=smaug

Comment 9

2 months ago
Pushed by amarchesini@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/13c70f92856e
HTMLInputElement should always allow popups for system principal, r=smaug
Assignee

Updated

2 months ago
Flags: needinfo?(amarchesini)

Comment 10

2 months ago
bugherder
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68
No longer blocks: 1459264
Flags: qe-verify+
Regressed by: 1459264

Comment 11

Last month

Verified as fixed on Firefox Nightly 68.0a1 (2019-05-03) on Windows 10 x 64, Windows 7 x32 and on Ubuntu 18.04 x64.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.