Intermittent tools/tryselect/test/test_presets.py::test_shared_presets[debugger-tests] TEST-UNEXPECTED-FAIL

RESOLVED FIXED in Firefox 67

Status

defect
P2
normal
RESOLVED FIXED
2 months ago
2 months ago

People

(Reporter: intermittent-bug-filer, Assigned: ahal)

Tracking

({intermittent-failure, regression})

unspecified
mozilla67

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox65 unaffected, firefox66 unaffected, firefox67 fixed)

Details

Attachments

(1 attachment)

Assignee

Updated

2 months ago
Assignee: nobody → ahal
Status: NEW → ASSIGNED
Priority: P5 → P2
Assignee

Comment 1

2 months ago

A couple observations:

  • The intermittent only started appearing after a second preset was added in bug 1532809. This is why it didn't fail when I initially created it.
  • It happens while loading the cached taskgraph generated by |mach try fuzzy| and is due to invalid JSON

So I believe pytest is running these tests in parallel and one test is writing the cache while the other is reading or something like that. If this is the case, the fix is pretty simple. Should have an answer soon.

See Also: → 1532809
Assignee

Comment 2

2 months ago

This makes sure this test doesn't actually generate tasks.

Duplicate of this bug: 1534649

Comment 4

2 months ago
Pushed by ahalberstadt@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/59cde22537a4
Fix intermittent failure in tools/tryselect/test/test_presets.py, r=gbrown

Comment 5

2 months ago
bugherder
Status: ASSIGNED → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
Comment hidden (Intermittent Failures Robot)
You need to log in before you can comment on or make changes to this bug.