Closed Bug 1534395 Opened 8 months ago Closed 7 months ago

Rename TabParent/TabChild to BrowserParent/BrowserChild

Categories

(Core :: DOM: Core & HTML, enhancement, P3)

enhancement

Tracking

()

RESOLVED FIXED
mozilla68
Tracking Status
firefox68 --- fixed

People

(Reporter: rhunt, Assigned: rhunt)

References

Details

Attachments

(6 files, 1 obsolete file)

TabParent and TabChild implement the PBrowser protocol. In bug 1523072 comment 11, we decided to rename the implementations to match the protocol for Fission.

The 'Tab' naming goes beyond these implementations into 'TabContext', 'TabId', and 'nsITabParent'. This bug is just for the first step of the protocol implementations.

Build is green on today's mozilla-central [1]. It's not very hard to rebase, thankfully.

[1] https://treeherder.mozilla.org/#/jobs?repo=try&revision=27d304e833a666c58538858597aec4df62649b1e

Component: DOM → DOM: Core & HTML

There's a r+ patch which didn't land and no activity in this bug for 2 weeks.
:rhunt, could you have a look please?

Flags: needinfo?(rhunt)

I've been on some PTO and decided there might be a better approach here, so I didn't land the patch here intentionally.

Flags: needinfo?(rhunt)
Attachment #9050087 - Attachment is obsolete: true

I've rebased all of the patches. Try looks green, need to do a larger test run, but should be good enough to start review.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=92e3411917573c9be52c3872c5793850fcaa8e37

File renames cause some unified build issues. This commit adds the missing headers.

nsITabParent is exposed to frontend code and is generally used as a representation of a remote tab. We could just rename the interface to nsIBrowserParent and worry about it later, but I think it's better to rename the interface to nsIRemoteTab so that we can later work on splitting the interface away from the PBrowser protocol.

Note: Some frontend code refers to a TabParentId. This commit renames this to RemoteTabId. We need to figure out the purpose of TabId with fission.

Depends on D28131

This commit renames TabParent to BrowserParent.

Depends on D28132

Similarly to nsITabParent, TabChild is exposed to frontend code via nsITabChild. It's not clear what the future of this interface will be, but for now we can just rename it to nsIBrowserChild.

Depends on D28133

This commit renames TabChild to BrowserChild.

Depends on D28134

Pushed by rhunt@eqrion.net:
https://hg.mozilla.org/integration/mozilla-inbound/rev/0d7938f30e54
Unified build fixes. r=nika
https://hg.mozilla.org/integration/mozilla-inbound/rev/e02c6844c4c3
Rename mRemoteBrowser to mBrowserParent in nsFrameLoader. r=nika
https://hg.mozilla.org/integration/mozilla-inbound/rev/96a7836e16e2
Rename nsITabParent to nsIRemoteTab. r=nika,mconley
https://hg.mozilla.org/integration/mozilla-inbound/rev/47813ecb1f4e
Rename TabParent to BrowserParent. r=nika
https://hg.mozilla.org/integration/mozilla-inbound/rev/9998ccf0c05f
Rename nsITabChild to nsIBrowserChild. r=nika,mconley
https://hg.mozilla.org/integration/mozilla-inbound/rev/9813ce146bc7
Rename TabChild to BrowserChild. r=nika
Pushed by rhunt@eqrion.net:
https://hg.mozilla.org/integration/mozilla-inbound/rev/5a2478c53c19
Fixup unified build bustage. r=me on a CLOSED TREE
Regressions: 1546850
No longer regressions: 1546850
You need to log in before you can comment on or make changes to this bug.