Closed Bug 1534466 Opened 2 years ago Closed 5 months ago

implement getSynchronizationSources for Video

Categories

(Core :: WebRTC, enhancement, P4)

enhancement

Tracking

()

RESOLVED FIXED
mozilla68
Tracking Status
firefox68 --- fixed
firefox78 --- fixed

People

(Reporter: ng, Assigned: ng, NeedInfo)

References

(Depends on 1 open bug)

Details

(Keywords: dev-doc-complete)

Attachments

(2 files)

getSynchronizationSources is not implemented for video, only audio where it's primary purpose is to get the audio levels of packets. This probably isn't too hard, however there hasn't been anyone asking for it yet either.

Rank: 39
No longer blocks: 1525394
Duplicate of this bug: 1525394
Assignee: nobody → na-g

I also filed: https://github.com/web-platform-tests/wpt/issues/15828, which is a bug against the test suite requiring the optional field 'voiceActivityFlag'.

Bug 1534466 - P1 refactor RtpSourceObserver to accept RTPHeader

Bug 1534466 - P2 Add RtpSourceObserver to VideoConduit

Bug 1534466 - P3 Update WPT ini to reflect newly passing tests

Reminder to self, land Monday 3/18.

Flags: needinfo?(na-g)

There's a r+ patch which didn't land and no activity in this bug for 2 weeks.
:ng, could you have a look please?

Flags: needinfo?(na-g)
Pushed by na-g@nostrum.com:
https://hg.mozilla.org/integration/autoland/rev/4f641f92edb2
implement getContributingSources and getSynchronizationSources for video r=jib
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68

We've got these documented, but we should probably update the compat data.

Keywords: dev-doc-needed
Flags: needinfo?(na-g)
Flags: needinfo?(na-g)

Did we previously have these in IDL and implemented to do nothing? I see no WebIDL changes here, which you normally do when API support is added for methods... according to the docs we already have in place, we have had these since Firefox 59. Was that audio only?

Flags: needinfo?(na-g)

I've performed the following updates:

  • Submitted BCD PR 4340 to add data about audio and video track support to getContributingSources() and getSynchronizationSources()
  • Added a bullet point to the WebRTC section on Firefox 68 for developers, under APIs

I'm not seeing any modifications to VideoConduit in this landing, and the wpt for video is still timing out. Did some part of this patchset get lost somehow?

Flags: needinfo?(na-g)

^

Flags: needinfo?(na-g)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Yes, looking at the patch is history in fabricator the changes to VideoConduit were dropped. I will see about this today.

Some of the changes were lost during a rebase before landing it. I have restored those changes, which had been reviewed previously, but a refactoring of the timestamp code means that some new changes needed to be made. This patch includes turning on the relavent WPTs which provide coverage.

Pushed by na-g@nostrum.com:
https://hg.mozilla.org/integration/autoland/rev/e102ee3e495a
P2 - add missing video impl for GetRtpSources;r=jib
Status: REOPENED → RESOLVED
Closed: 2 years ago5 months ago
Resolution: --- → FIXED
Depends on: 1646904
You need to log in before you can comment on or make changes to this bug.