Closed Bug 1534687 Opened 5 years ago Closed 1 month ago

RTCRtpParameters.codecs aren't populated

Categories

(Core :: WebRTC: Signaling, enhancement, P3)

enhancement

Tracking

()

RESOLVED FIXED
128 Branch
Tracking Status
firefox128 --- fixed

People

(Reporter: bwc, Assigned: bwc)

References

(Blocks 1 open bug, Regressed 1 open bug)

Details

(Keywords: dev-doc-complete)

Attachments

(2 files)

No description provided.
Severity: normal → S3
Blocks: 1531464

Includes some tests that compat mode ignores any attempt to set .codecs.

Assignee: nobody → docfaraday
Status: NEW → ASSIGNED

We do not mark this field as required right now, because we still have users
that synthesize RTCRtpParameters instead of tweaking the return of
getParameters. The compat mode will ignore any attempt to modify .codecs,
otherwise this will result in the error specified in webrtc-pc.

Depends on D209304

Duplicate of this bug: 1531464
Pushed by bcampen@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/42c06449d631
Test cases for RTCRtpParameters.codecs. r=jib
https://hg.mozilla.org/integration/autoland/rev/1edceea62ecd
Implement RTCRtpParameters.codecs and RTCRtpReceiver.getParameters r=jib,webidl,smaug
Created web-platform-tests PR https://github.com/web-platform-tests/wpt/pull/46610 for changes under testing/web-platform/tests
Regressions: 1900517
Regressions: 1900518
Status: ASSIGNED → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED
Target Milestone: --- → 128 Branch
Upstream PR merged by moz-wptsync-bot
Regressions: 1900598
Regressions: 1900600

FYI MDN FF128 docs work for this tracked in https://github.com/mdn/content/issues/33988 (in review)

You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: