need to specify RDF xmlns in overlay

VERIFIED FIXED in M13

Status

()

Core
Internationalization
P3
normal
VERIFIED FIXED
19 years ago
18 years ago

People

(Reporter: shaver, Assigned: cata)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: Asked reporter for more informations., URL)

The overlay in question uses the RDF namespace (rdf:type), but never sets it up.
This will result in the attributes being ignored, which is probably not what you
want.

Updated

19 years ago
Assignee: ftang → cata

Comment 1

19 years ago
cata, charsetOverlay.xul is your file.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M12
(Assignee)

Updated

19 years ago
Whiteboard: Fix in local tree, waiting to checking when public tree opens.
(Assignee)

Comment 2

19 years ago
Problem was with bogus rules not being used anymore, but still being there.
(Assignee)

Updated

19 years ago
Whiteboard: Fix in local tree, waiting to checking when public tree opens.
(Assignee)

Comment 3

19 years ago
Oops! Please discard my latest comment, it was intended for a different bug.

Comment 4

19 years ago
How does one set up the RDF namespace? Is there an example of that in the tree?
(Assignee)

Updated

18 years ago
Target Milestone: M12 → M13
(Assignee)

Updated

18 years ago
Blocks: 20761
(Assignee)

Updated

18 years ago
Whiteboard: Asked reporter for more informations.

Comment 5

18 years ago
this is a real no-brainer. all that needs to be done is add:

  xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"

to the <window> tag. For an example, see:

http://lxr.mozilla.org/seamonkey/source/xpfe/components/bookmarks/resources/bookmarks.xul#31
(Assignee)

Comment 6

18 years ago
Great! Thanks! I'll do it asap.
(Assignee)

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 7

18 years ago
I fixed it, applying waterson's suggestion.

Comment 8

18 years ago
Changed QA contact to cata@netscape.com.  Cata, please mark this as verified.
QA Contact: teruko → cata
(Assignee)

Comment 9

18 years ago
And it is verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.