Closed Bug 1534925 Opened 1 year ago Closed 1 year ago

When simulating mobile devices in developer tools, typing text into an input field will trigger search bar instead of entering the text into the input field.

Categories

(DevTools :: Responsive Design Mode, defect, P1)

65 Branch
defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: f.settelmeyer, Assigned: mtigley)

References

Details

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:65.0) Gecko/20100101 Firefox/65.0

Steps to reproduce:

  1. I open developer tools on a website containing an input field.
  2. I trigger mobile device simulation (CRTL + SHIFT + M)
  3. I click on the input field. The cursor appears inside of it.
  4. I start typing.

Actual results:

The input field loses focus. The quick search bar appears at the bottom of the website.

Expected results:

The quick search bar should not have openend and the text should have been entered into the input field.

Component: Untriaged → Responsive Design Mode
Product: Firefox → DevTools

Reproducing this requires the accessibility.typeaheadfind pref to be true.

Sounds very similar to bug 1317323, but happens with all characters when you have the search as you type feature on.

Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P1
See Also: → 1317323
Assignee: nobody → mtigley
Status: NEW → ASSIGNED
Whiteboard: [rdm-mvp]

This may also be a duplicate of Bug 1322385. Setting this as depending on Bug 1322385 since it may also resolve this issue when it lands.

Depends on: 1322385

Has been resolved by work on Bug 1322385

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Whiteboard: [rdm-mvp]
You need to log in before you can comment on or make changes to this bug.