Closed Bug 1535139 Opened 9 months ago Closed 8 months ago

Startup Crash on Android Q emulator

Categories

(GeckoView :: General, defect, P1)

Unspecified
Android
defect

Tracking

(firefox65 wontfix, firefox66 wontfix, firefox67 fix-optional, firefox68 affected)

RESOLVED DUPLICATE of bug 1535196
Tracking Status
firefox65 --- wontfix
firefox66 --- wontfix
firefox67 --- fix-optional
firefox68 --- affected

People

(Reporter: Agi, Unassigned)

References

Details

(Keywords: crash, Whiteboard: [geckoview:fenix:p2])

I get a crash when trying to launch GeckoView Example on the x86 emulator on an Android Q preview build. May be related to Bug 1518056.

********** Crash dump: **********
Build fingerprint: 'google/sdk_gphone_x86/generic_x86:Q/QPP1.190205.018.B3/5345599:userdebug/dev-keys'
pid: 6636, tid: 6708, name: LoadRoots  >>> org.mozilla.geckoview_example <<<
signal 11 (SIGSEGV), code 1 (SEGV_MAPERR), fault addr 0x9c8c3780
Stack frame #00 pc 00047d59  /data/app/org.mozilla.geckoview_example-QsWnQQPo8I7dD3X1_2JazQ==/lib/x86/libnssckbi.so
Stack frame #01 pc 0004ab3a  /data/app/org.mozilla.geckoview_example-QsWnQQPo8I7dD3X1_2JazQ==/lib/x86/libnssckbi.so
Stack frame #02 pc 0004a503  /data/app/org.mozilla.geckoview_example-QsWnQQPo8I7dD3X1_2JazQ==/lib/x86/libnssckbi.so
Stack frame #03 pc 00046965  /data/app/org.mozilla.geckoview_example-QsWnQQPo8I7dD3X1_2JazQ==/lib/x86/libnssckbi.so
Stack frame #04 pc 0004bc11  /data/app/org.mozilla.geckoview_example-QsWnQQPo8I7dD3X1_2JazQ==/lib/x86/libnssckbi.so
Stack frame #05 pc 000440ac  /data/app/org.mozilla.geckoview_example-QsWnQQPo8I7dD3X1_2JazQ==/lib/x86/libnssckbi.so
Stack frame #06 pc 00150036  /data/app/org.mozilla.geckoview_example-QsWnQQPo8I7dD3X1_2JazQ==/lib/x86/libnss3.so
Stack frame #07 pc 001593fe  /data/app/org.mozilla.geckoview_example-QsWnQQPo8I7dD3X1_2JazQ==/lib/x86/libnss3.so (SECMOD_LoadModule+340)
Stack frame #08 pc 001595e4  /data/app/org.mozilla.geckoview_example-QsWnQQPo8I7dD3X1_2JazQ==/lib/x86/libnss3.so (SECMOD_LoadUserModule+45)
Stack frame #09 pc 0242e54e  /data/app/org.mozilla.geckoview_example-QsWnQQPo8I7dD3X1_2JazQ==/lib/x86/libxul.so: Routine mozilla::psm::LoadLoadableRoots(nsTString<char> const&) at /Users/asferro/workspace/gecko-dev/security/certverifier/NSSCertDBTrustDomain.cpp:1172
Stack frame #10 pc 04dd888a  /data/app/org.mozilla.geckoview_example-QsWnQQPo8I7dD3X1_2JazQ==/lib/x86/libxul.so: Routine LoadLoadableRootsTask::LoadLoadableRoots() at /Users/asferro/workspace/gecko-dev/security/manager/ssl/nsNSSComponent.cpp:915
Stack frame #11 pc 04dd8789  /data/app/org.mozilla.geckoview_example-QsWnQQPo8I7dD3X1_2JazQ==/lib/x86/libxul.so: Routine LoadLoadableRootsTask::Run() at /Users/asferro/workspace/gecko-dev/security/manager/ssl/nsNSSComponent.cpp:649
Stack frame #12 pc 024d0305  /data/app/org.mozilla.geckoview_example-QsWnQQPo8I7dD3X1_2JazQ==/lib/x86/libxul.so: Routine nsThread::ProcessNextEvent(bool, bool*) at /Users/asferro/workspace/gecko-dev/xpcom/threads/nsThread.cpp:1179
Stack frame #13 pc 024d1e5f  /data/app/org.mozilla.geckoview_example-QsWnQQPo8I7dD3X1_2JazQ==/lib/x86/libxul.so: Routine NS_ProcessNextEvent(nsIThread*, bool) at /Users/asferro/workspace/gecko-dev/xpcom/threads/nsThreadUtils.cpp:482
Stack frame #14 pc 028be297  /data/app/org.mozilla.geckoview_example-QsWnQQPo8I7dD3X1_2JazQ==/lib/x86/libxul.so: Routine mozilla::ipc::MessagePumpForNonMainThreads::Run(base::MessagePump::Delegate*) at /Users/asferro/workspace/gecko-dev/ipc/glue/MessagePump.cpp:333
Stack frame #15 pc 02889f86  /data/app/org.mozilla.geckoview_example-QsWnQQPo8I7dD3X1_2JazQ==/lib/x86/libxul.so: Routine MessageLoop::RunInternal() at /Users/asferro/workspace/gecko-dev/ipc/chromium/src/base/message_loop.cc:315
Stack frame #16 pc 024ce86a  /data/app/org.mozilla.geckoview_example-QsWnQQPo8I7dD3X1_2JazQ==/lib/x86/libxul.so: Routine nsThread::ThreadFunc(void*) at /Users/asferro/workspace/gecko-dev/xpcom/threads/nsThread.cpp:454
Stack frame #17 pc 0011a9af  /data/app/org.mozilla.geckoview_example-QsWnQQPo8I7dD3X1_2JazQ==/lib/x86/libnss3.so
Stack frame #18 pc 0011c645  /bionic/lib/libc.so (__pthread_start(void*)+53)
Stack frame #19 pc 000b14d7  /bionic/lib/libc.so (__start_thread+71)

[geckoview:fenix:m4] because we should fix this before Fenix MVP, but (I assume!) fixing this crash is not an urgent blocker because GV developers can use older Android emulator images.

Blocks: 1518056
Keywords: crash
OS: All → Android
Priority: -- → P1
Whiteboard: [geckoview:fenix:m4]

:snorp reported that he doesn't see this crash and I can also run gv apps fine on my Pixel2, so this might be just a weirdness in either the Mac android emulator or my laptop.

Deferring to Fenix M5. This is not an urgent priority because Fenix MVP will be released before Android Q.

Whiteboard: [geckoview:fenix:m4] → [geckoview:fenix:m5]

Demoting to priority [geckoview:fenix:p2] because Android Q support is not a Fenix MVP release blocker.

Whiteboard: [geckoview:fenix:m5] → [geckoview:fenix:p2]

Agi does building an aarch64 GV run?

Flags: needinfo?(agi)
Blocks: android-q

Kevin sounds like your theory is correct: aarch64 doesn't crash while armv7 does crash on my Pixel 2 with Android Q.

Flags: needinfo?(agi)

Going to dupe this to the bug that has more investigation.

Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1535196
No longer blocks: android-q
You need to log in before you can comment on or make changes to this bug.