Closed Bug 1535580 Opened 2 years ago Closed 2 years ago

Tier 2 Perma make[4]: *** [libclang-plugin.so] Error 1

Categories

(Webtools :: Searchfox, defect, P5)

defect

Tracking

(firefox67 fixed)

RESOLVED FIXED
Tracking Status
firefox67 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: froydnj)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

#[markdown(off)]
Filed by: aiakab [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=234094175&repo=mozilla-central

https://queue.taskcluster.net/v1/task/EE7yXNt-TgeYhdyCYDT7Zg/runs/0/artifacts/public/logs/live_backing.log

[task 2019-03-15T10:05:14.384Z] 10:05:14 INFO - make[4]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox/build/clang-plugin'
[task 2019-03-15T10:05:18.332Z] 10:05:18 INFO - make[4]: Entering directory '/builds/worker/workspace/build/src/obj-firefox/build/clang-plugin'
[task 2019-03-15T10:05:18.333Z] 10:05:18 INFO - /builds/worker/workspace/build/src/clang/bin/clang++ -o host_MozsearchIndexer.o -c -I/builds/worker/workspace/build/src/clang/include -fPIC -Qunused-arguments -fPIC -fvisibility-inlines-hidden -Werror=date-time -Werror=unguarded-availability-new -std=c++11 -Wall -Wextra -Wno-unused-parameter -Wwrite-strings -Wcast-qual -Wmissing-field-initializers -pedantic -Wno-long-long -Wcovered-switch-default -Wnon-virtual-dtor -Wdelete-non-virtual-dtor -Wstring-conversion -fdiagnostics-color -ffunction-sections -fdata-sections -O3 -DNDEBUG -fno-exceptions -fno-rtti -D_GNU_SOURCE -D__STDC_CONSTANT_MACROS -D__STDC_FORMAT_MACROS -D__STDC_LIMIT_MACROS -DHAVE_NEW_ASTMATCHER_NAMES -DHAS_ACCEPTS_IGNORINGPARENIMPCASTS -fno-rtti -fno-exceptions -O3 -DDEBUG=1 -I/builds/worker/workspace/build/src/build/clang-plugin -I/builds/worker/workspace/build/src/obj-firefox/build/clang-plugin -I/builds/worker/workspace/build/src/obj-firefox/dist/include -MD -MP -MF .deps/host_MozsearchIndexer.o.pp -I/builds/worker/workspace/build/src/obj-firefox/dist/include/nspr /builds/worker/workspace/build/src/build/clang-plugin/mozsearch-plugin/MozsearchIndexer.cpp
[task 2019-03-15T10:05:18.333Z] 10:05:18 INFO - make[4]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox/build/clang-plugin'
[task 2019-03-15T10:05:18.333Z] 10:05:18 INFO - make[4]: Entering directory '/builds/worker/workspace/build/src/obj-firefox/build/clang-plugin'
[task 2019-03-15T10:05:18.333Z] 10:05:18 INFO - build/clang-plugin/libclang-plugin.so
[task 2019-03-15T10:05:18.333Z] 10:05:18 INFO - rm -f libclang-plugin.so
[task 2019-03-15T10:05:18.333Z] 10:05:18 INFO - make[4]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox/build/clang-plugin'
[task 2019-03-15T10:05:18.393Z] 10:05:18 INFO - make[4]: Entering directory '/builds/worker/workspace/build/src/obj-firefox/build/clang-plugin'
[task 2019-03-15T10:05:18.394Z] 10:05:18 INFO - /builds/worker/workspace/build/src/clang/bin/clang++ -o libclang-plugin.so host_ArithmeticArgChecker.o host_AssertAssignmentChecker.o host_CanRunScriptChecker.o host_CustomAttributes.o host_CustomTypeAnnotation.o host_DanglingOnTemporaryChecker.o host_DiagnosticsMatcher.o host_ExplicitImplicitChecker.o host_ExplicitOperatorBoolChecker.o host_KungFuDeathGripChecker.o host_MozCheckAction.o host_MustOverrideChecker.o host_MustReturnFromCallerChecker.o host_MustUseChecker.o host_NaNExprChecker.o host_NeedsNoVTableTypeChecker.o host_NoAddRefReleaseOnReturnChecker.o host_NoAutoTypeChecker.o host_NoDuplicateRefCntMemberChecker.o host_NoExplicitMoveConstructorChecker.o host_NonMemMovableMemberChecker.o host_NonMemMovableTemplateArgChecker.o host_NonParamInsideFunctionDeclChecker.o host_OverrideBaseCallChecker.o host_OverrideBaseCallUsageChecker.o host_ParamTraitsEnumChecker.o host_RefCountedCopyConstructorChecker.o host_RefCountedInsideLambdaChecker.o host_ScopeChecker.o host_SprintfLiteralChecker.o host_TrivialCtorDtorChecker.o host_VariableUsageHelpers.o host_FileOperations.o host_JSONFormatter.o host_MozsearchIndexer.o host_StringOperations.o host_ThirdPartyPaths.o -I/builds/worker/workspace/build/src/clang/include -fPIC -Qunused-arguments -fPIC -fvisibility-inlines-hidden -Werror=date-time -Werror=unguarded-availability-new -std=c++11 -Wall -Wextra -Wno-unused-parameter -Wwrite-strings -Wcast-qual -Wmissing-field-initializers -pedantic -Wno-long-long -Wcovered-switch-default -Wnon-virtual-dtor -Wdelete-non-virtual-dtor -Wstring-conversion -fdiagnostics-color -ffunction-sections -fdata-sections -O3 -DNDEBUG -fno-exceptions -fno-rtti -D_GNU_SOURCE -D__STDC_CONSTANT_MACROS -D__STDC_FORMAT_MACROS -D__STDC_LIMIT_MACROS -DHAVE_NEW_ASTMATCHER_NAMES -DHAS_ACCEPTS_IGNORINGPARENIMPCASTS -fno-rtti -fno-exceptions -O3 -L/builds/worker/workspace/build/src/clang/lib -lclangASTMatchers -shared
[task 2019-03-15T10:05:18.395Z] 10:05:18 INFO - /usr/bin/ld: BFD (GNU Binutils for Debian) 2.22 internal error, aborting at ../../bfd/reloc.c line 443 in bfd_get_reloc_size
[task 2019-03-15T10:05:18.395Z] 10:05:18 INFO - /usr/bin/ld: Please report this bug.
[task 2019-03-15T10:05:18.395Z] 10:05:18 INFO - clang-7: [0;1;31merror: [0mlinker command failed with exit code 1 (use -v to see invocation)[0m
[task 2019-03-15T10:05:18.396Z] 10:05:18 INFO - /builds/worker/workspace/build/src/config/rules.mk:653: recipe for target 'libclang-plugin.so' failed
[task 2019-03-15T10:05:18.396Z] 10:05:18 ERROR - make[4]: *** [libclang-plugin.so] Error 1
[task 2019-03-15T10:05:18.396Z] 10:05:18 INFO - make[4]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox/build/clang-plugin'
[task 2019-03-15T10:05:18.396Z] 10:05:18 INFO - /builds/worker/workspace/build/src/config/recurse.mk:74: recipe for target 'build/clang-plugin/host' failed
[task 2019-03-15T10:05:18.396Z] 10:05:18 ERROR - make[3]: *** [build/clang-plugin/host] Error 2
[task 2019-03-15T10:05:18.396Z] 10:05:18 INFO - /builds/worker/workspace/build/src/config/recurse.mk:32: recipe for target 'compile' failed
[task 2019-03-15T10:05:18.396Z] 10:05:18 ERROR - make[2]: *** [compile] Error 2
[task 2019-03-15T10:05:18.396Z] 10:05:18 INFO - /builds/worker/workspace/build/src/config/rules.mk:400: recipe for target 'default' failed
[task 2019-03-15T10:05:18.396Z] 10:05:18 ERROR - make[1]: *** [default] Error 2
[task 2019-03-15T10:05:18.396Z] 10:05:18 INFO - client.mk:125: recipe for target 'build' failed
[task 2019-03-15T10:05:18.396Z] 10:05:18 INFO - make: *** [build] Error 2
[task 2019-03-15T10:05:18.412Z] 10:05:18 INFO - 0 compiler warnings present.
[task 2019-03-15T10:05:18.474Z] 10:05:18 ERROR - Return code: 2
[task 2019-03-15T10:05:18.474Z] 10:05:18 WARNING - setting return code to 2
[task 2019-03-15T10:05:18.474Z] 10:05:18 FATAL - 'mach build -v' did not run successfully. Please check log for errors.
[task 2019-03-15T10:05:18.474Z] 10:05:18 FATAL - Running post_fatal callback...
[task 2019-03-15T10:05:18.475Z] 10:05:18 FATAL - Exiting -1
[task 2019-03-15T10:05:18.475Z] 10:05:18 INFO - [mozharness: 2019-03-15 10:05:18.475018Z] Finished build step (failed)
[task 2019-03-15T10:05:18.475Z] 10:05:18 INFO - Running post-run listener: _parse_build_tests_ccov
[task 2019-03-15T10:05:18.475Z] 10:05:18 INFO - Running post-run listener: _shutdown_sccache
[task 2019-03-15T10:05:18.475Z] 10:05:18 INFO - Running post-run listener: _summarize
[task 2019-03-15T10:05:18.475Z] 10:05:18 ERROR - # TBPL FAILURE #
[task 2019-03-15T10:05:18.475Z] 10:05:18 INFO - [mozharness: 2019-03-15 10:05:18.475208Z] FxDesktopBuild summary:
[task 2019-03-15T10:05:18.475Z] 10:05:18 ERROR - # TBPL FAILURE #
[taskcluster 2019-03-15 10:05:19.039Z] === Task Finished ===
[taskcluster 2019-03-15 10:05:19.873Z] Unsuccessful task run with exit code: 255 completed in 221.834 seconds

Summary: Intermittent make[4]: *** [libclang-plugin.so] Error 1 → Tier 2 Perma make[4]: *** [libclang-plugin.so] Error 1

Almost certainly due to bug 1451104

Blocks: 1451104
Flags: needinfo?(nfroyd)
Flags: needinfo?(mh+mozilla)

The searchfox jobs need to install the linux64-binutils toolchain and ensure that $topsrcdir/binutils/bin is on PATH. I can look at doing this this morning.

Flags: needinfo?(nfroyd)
Flags: needinfo?(mh+mozilla)

... or switch to debian 9 like the plain builds did.

(In reply to Mike Hommey [:glandium] from comment #3)

... or switch to debian 9 like the plain builds did.

Either way works for me. I think it's a little bit confusing that the normal cross builds would use linux64-binutils and the searchfox builds wouldn't in that case, but maybe that's OK.

Changing mozconfigs and whatnot would be slightly more complicated, because the linux64 searchfox config doesn't go through mozconfig.unix. I think it's ok to use mozconfig.unix there, but it's less obviously correct.

We need to install a new enough binutils for both of these jobs and
ensure that it's properly found on the linux job.

I went the binutils route because changing the base image resulted in bad GLIBC symbols in NSPR, and I didn't want to bother tracking those down. (I guess we could have turned off libstdc++ compat, but the binutils changes seemed mildly more consistent.)

Pushed by nfroyd@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9a96eceffaee
update linux/mac searchfox jobs for clang changes; r=kats
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Assignee: nobody → nfroyd
Keywords: regression
You need to log in before you can comment on or make changes to this bug.