Closed Bug 1535589 Opened 7 months ago Closed 7 months ago

Firefox 65.0.2 started crashing on 2019-03-15 with Avast and the Ghostery addon

Categories

(External Software Affecting Firefox :: Other, defect)

defect
Not set

Tracking

(firefox65-, firefox66- fix-optional)

RESOLVED INVALID
Tracking Status
firefox65 - ---
firefox66 - fix-optional

People

(Reporter: forumnews, Unassigned, NeedInfo)

Details

Attachments

(1 file)

Attached image crash.jpg

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:65.0) Gecko/20100101 Firefox/65.0

Steps to reproduce:

He was working regularly for a month "ghostery" plugin.
https://addons.mozilla.org/en-US/firefox/user/10565426/

It caused collapse as of yesterday!

Actual results:

If "Ghostery" is on, Firefox crashes in 5 seconds!

After opening Firefox you have 5 seconds to turn it off! Turn it off immediately!

Please post the crash ID from about:crashes

An extension can only trigger a crash but is not the cause of it unless it's a "Out of Memory" crash.

Flags: needinfo?(forumnews)

We've gotten multiple reports from Ghostery users stating the same. It seems to have started with 65.0.2. Here's a crash report from one of our test machines.

https://crash-stats.mozilla.com/report/index/d814277d-5884-4fb1-87af-fc0340190315

It crashed immediately on launch but then was fine after that. We haven't been able to trigger recurring crashes, although many users are having that issue.

That crash report is bug 1487194 but are you sure that it's a crash report from the ghostery problem ?
That crash seems to happen on a browser shutdown.

this is also getting reported in various addon reviews and on sumo in the past hours:
https://addons.mozilla.org/firefox/addon/ghostery/reviews/
https://support.mozilla.org/en-US/questions/firefox?owner=all&tagged=bug1535589&show=all

(In reply to Christopher Tino from comment #3)

We've gotten multiple reports from Ghostery users stating the same. It seems to have started with 65.0.2.

the reports are starting to show up today - firefox 65.0.2 got released over 2 weeks ago, so there's likely no direct relation there (other than it's the most common version of the browser by now for users on the release channel)

(In reply to [:philipp] from comment #5)

the reports are starting to show up today - firefox 65.0.2 got released over 2 weeks ago, so there's likely no direct relation there (other than it's the most common version of the browser by now for users on the release channel)

We noticed that as well. It seems like many of us didn't get the 65.0.2 update until today. I have one machine still on 65.0.1 that hasn't gotten it. Likewise, we haven't pushed a new Ghostery version since the end of January so I'm struggling to figure out why so many users are all of a sudden effected by this.

(In reply to Christopher Tino from comment #6)

Likewise, we haven't pushed a new Ghostery version since the end of January so I'm struggling to figure out why so
many users are all of a sudden effected by this.

such issues being introduced out of update cycles are often triggered by signature/behavioural updates to security software.
two affected users are reportedly using avast (not a large sample size i admit), but i was able to reproduce firefox crashes with windows error reports after installing the free version of avast with just the most basic protection modules pretty much out of the box (and it was solved again after avast got uninstalled).

lukas, are you aware of any change in today's signature updates that might trigger such a 3-way interference with the ghostery addon and firefox 65.0.2?

Component: Untriaged → Other
Flags: needinfo?(rypacek)
Product: Firefox → External Software Affecting Firefox
Summary: The Ghostery plugin is causing the crash! → Firefox 65.0.2 started crashing on 2019-03-15 with Avast and the Ghostery addon

Romain, can you try talking with Avast folks about this? It is a major issue.

Flags: needinfo?(rtestard)

as requested by ghostery developers, those are the crash IDs I have uploaded:

Firefox 65.0.2 on Windows

(In reply to Matthias Versen [:Matti] from comment #4)

That crash report is bug 1487194 but are you sure that it's a crash report from the ghostery problem ?
That crash seems to happen on a browser shutdown.

I'm sure yes.
If I open Firefox and go to add-ons within 5 seconds and turn off ghostery, there is no crash!

But this is not happening in version 66.0 (64-bit) Win7 (Ultimate)

I have V.66 in my system right now.
Ghostery is running smoothly. :)

V.66.0 (64-bit) is currently running stable.

Note:

  • AVG Antivirus was installed on my system.
    The settings have not changed.

  • The problem is probably in version 65.0.0.6995.

Status: UNCONFIRMED → RESOLVED
Closed: 7 months ago
Flags: needinfo?(forumnews)
Resolution: --- → INVALID

the crash reports from comment#9 are probably bug 1484524 (fixed on trunk)

Bug 1484524 was also fixed in 66 last week.

Flags: needinfo?(rtestard)

Avast may have backed out a change that caused the crash. If you run into this try updating Avast/AVG.

The user reports seem to be letting up on our end as well. It would still be good to know what caused the crashes and see if there's something we can do on our side to prevent them.

Hello everyone!

I tried to reproduce this issue, but to no avail. Here are the combinations I tried:

  • Avast 19.3.2369 (build 19.3.4241.439) Windows 10 x64 with Ghostery addon on Fx 65.0, 65.0.1 and 65.0.2.
  • AVG 19.3.3084 (build ID 19.3.4241.439) Windows 10 x64, with Ghostery addon on Fx 65.0, 65.0.1 and 65.0.2.
  • Avast 19.3.2369 (build 19.3.4241.439) Windows 10 x32 with Ghostery addon on Fx 65.0, 65.0.1 and 65.0.2.
  • AVG 19.3.3084 (build ID 19.3.4241.439) Windows 10 x32, with Ghostery addon on Fx 65.0, 65.0.1 and 65.0.2.

I tried to run Firefox on several news websites and youtube and restarted it a couple of times.

Did I miss something?

Thank you.

(In reply to Cristian Comorasu [:ccomorasu], Release Desktop QA from comment #15)

Hello everyone!

I tried to reproduce this issue, but to no avail. Here are the combinations I tried:

  • Avast 19.3.2369 (build 19.3.4241.439) Windows 10 x64 with Ghostery addon on Fx 65.0, 65.0.1 and 65.0.2.
  • AVG 19.3.3084 (build ID 19.3.4241.439) Windows 10 x64, with Ghostery addon on Fx 65.0, 65.0.1 and 65.0.2.
  • Avast 19.3.2369 (build 19.3.4241.439) Windows 10 x32 with Ghostery addon on Fx 65.0, 65.0.1 and 65.0.2.
  • AVG 19.3.3084 (build ID 19.3.4241.439) Windows 10 x32, with Ghostery addon on Fx 65.0, 65.0.1 and 65.0.2.

I tried to run Firefox on several news websites and youtube and restarted it a couple of times.

Did I miss something?

Thank you.

Hello Cristian,
I have the problem in version 65.0.0.6995.
Firefox was completely crashing!
If I disable Ghostery, there was no crash!
AVG is running in my system. (19.3.3084 (build 19.3.4241.439))

No need to enter news sites for crash.
If Ghostery is active it crashes in 5-10 seconds when Firefox opens!
In 5-10 seconds, add-ons go down and ghostery shuts down, so there's no crash!

V.66 also works smoothly.
Today I went to 67.0 Beta 3. (Beta Update Channel)
Ghostery working properly.

Can you please provide us with the link where you downloaded this Firefox build?

Flags: needinfo?(forumnews)

(In reply to Cristian Comorasu [:ccomorasu], Release Desktop QA from comment #17)

Can you please provide us with the link where you downloaded this Firefox build?

65.0.0.6995 version had come with update.
I don't know if there's an Exe link somewhere.

Flags: needinfo?(forumnews)
You need to log in before you can comment on or make changes to this bug.