Closed Bug 1535721 Opened 2 years ago Closed 1 month ago

Resuming from suspend fails to create opengl context => graphics crash

Categories

(Core :: Graphics, defect, P3)

65 Branch
defect

Tracking

()

RESOLVED DUPLICATE of bug 1656361

People

(Reporter: benland100, Unassigned)

References

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:65.0) Gecko/20100101 Firefox/65.0

Steps to reproduce:

  • Suspend machine with firefox open.
  • Resume machine.
  • Click around firefox a bit ("helps" if open tabs are graphics heavy - Gmail PDF viewer, Facebook, Youtube, etc.)
  • Large portions of GUI disappear, turn black, or become non-functional

Actual results:

Coincident with graphical failure, stderr shows:

Unflushed glGetGraphicsResetStatus: 0x92bb
Crash Annotation GraphicsCriticalError: |[0][GFX1-]: [OPENGL] Failed to init compositor with reason: FEATURE_FAILURE_OPENGL_CREATE_CONTEXT (t=90.9998) [GFX1-]: [OPENGL] Failed to init compositor with reason: FEATURE_FAILURE_OPENGL_CREATE_CONTEXT

Ultimately the firefox process must be force killed and restarted to recover.

Expected results:

Firefox should not become unusable after suspend/resume.

This occurs on (gentoo) linux using nvidia-drivers 418.43 (GTX1060) and kernel 5.0.2. I've been experiencing this for some months since kernel 4.19 and a few recent nvidia-drivers version, however firefox seems to be the only program affected this, so filing the bug here.

I have attempted to reproduce this issue on a laptop with Ubuntu 16.04 LTS with Intel HD Graphics 550 integrated graphics card and on an AMD desktop PC with ATI Radeon 3000 graphics card on Ubuntu 18.10 and Ubuntu 16.04 LTS, but I could not reproduce it.
The test was performed on Firefox Release v65.0.2 and Firefox Nightly v68.0a1.
Someone with a fairly new NVidia graphics card should also attempt to reproduce it.

Component: Untriaged → Graphics
Product: Firefox → Core

I've updated to v66 and the issue remains, however the behavior is subtly different: now large parts of the GUI become transparent when this happens.

That bit of information led me to https://bugzilla.mozilla.org/show_bug.cgi?id=1511508 so this bug seems to be a duplicate.

I assume you have 'layers.acceleration.force-enabled' set?

Flags: needinfo?(benland100)

That's correct, layers.acceleration.force-enabled is set. I thought at some point in the distant past I had set that manually, but "true" appears to be the default now.

Flags: needinfo?(benland100)

"true" should not be the default. (It's sort of in the name :) ) What makes you think that it is?

layers.acceleration.force-enabled on Nvidia binary drivers isn't a configuration that we're putting a lot of work into fixing so I don't expect a fix soon.

Flags: needinfo?(benland100)

This screenshot https://ben.land/files/c2z2FIEG.png from about:config definitely suggests that the default value is true.
Arguably I might be misinterpreting something here.

Flags: needinfo?(benland100)

Weird, is this a build from Mozilla or a distro build?

Flags: needinfo?(benland100)

This is a gentoo build, and it looks like there is a use flag to force enable hardware acceleration, so that clears that up.

That said, I've been using hardware acceleration in firefox with nvidia binary drivers on linux for quite some time before this with no issues, and it would be great to get this issue resolved.

Flags: needinfo?(benland100)

Considering the existence of bug 1511508, should one of them be marked as a duplicate of the other? Do you think that it's the same issue of could be different ones?

Flags: needinfo?(jbonisteel)
See Also: → 1511508
Flags: needinfo?(jbonisteel)
Priority: -- → P3

Still affects 78.0.2 and current Nightly. The only fix is rebooting the system (though I haven't tried restarting the X session).

Arch Linux, nvidia 450.57, GNOME on X11

To be clear, there is no graphical distortion, but WebRender cannot be initialised and falls back to OpenGL rendering instead. The error log shows "Unflushed glGetGraphicsResetStatus: 0x92bb" as happened to the original reporter.

I ran into this as well on "Pop! OS". Their build has:

$ cat /usr/lib/firefox/defaults/pref/pop-default-settings.js 
pref("layers.acceleration.force-enabled", true);
pref("widget.content.gtk-theme-override", "Pop");

Filed a bug with them here: https://github.com/pop-os/pop/issues/1249

I'm running nvidia drivers, so I don't blame Firefox for not wanting to debug this. Just thought I'd mention it for any other Pop! OS users that end up here.

I'll try setting layers.acceleration.force-enabled false.

Status: UNCONFIRMED → RESOLVED
Closed: 1 month ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1656361

FYI this does not appear to be resolved. I just tested this with firefox 84 using nvidia drivers 455.45.01, and get the same behavior as reported. Unclear why this was marked resolved, or as a duplicate of a much newer issue. Certainly the update to nvidia drivers didn't resolve it, but happy to test with a newer firefox if there was some change that should fix this issue that's not in firefox 84.

Please test with Nightly tomorrow:
bug 1656361 was closed as duplicate of bug 1682876. Thanks!

(When testing Nightly tomorrow, please set gfx.webrender.all to true and restart Nightly to use the new OpenGL rendering engine. layers.acceleration.force-enabled is deprecated.)

You need to log in before you can comment on or make changes to this bug.