Load new tab pocket article images closer to when they might be shown

RESOLVED DUPLICATE of bug 1531933

Status

()

enhancement
P1
normal
RESOLVED DUPLICATE of bug 1531933
a month ago
13 days ago

People

(Reporter: gsuntop, Assigned: gsuntop)

Tracking

(Blocks 2 bugs)

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

a month ago

Don't load assets that are outside of the immediate viewport until scroll position gets within a certain threshold TBD.

Severity: normal → enhancement
No longer blocks: 1512725

Updated

a month ago
See Also: → 1535693

https://github.com/mbrevda/react-image and https://github.com/joshwnj/react-visibility-sensor#readme together could implement this.

I'm not sure that it's worth taking more dependencies for this (though it's not necessarily out of the question), but even if not, they may be helpful as inspirations.

Also worth noting is that it looks like at least some of react-image functionality will be provided via React itself mid-2019: https://reactjs.org/blog/2018/11/27/react-16-roadmap.html#react-16x-mid-2019-the-one-with-suspense-for-data-fetching

(Assignee)

Updated

a month ago
Summary: Add lazy loading → Add lazy loading for images
Iteration: 68.1 - Mar 18 - 31 → 68.2 - Apr 1 - 14

Comment 2

17 days ago

Has anyone thought about the privacy implications of this yet, especially for e.g. 3rd party content? Or the negative economic impact for webmasters in the case of ads (e.g. being marked as a non-load while the page was loaded). I mean, it's cool if you can save a few KB of bandwidth, but I see plenty of potential abuse here too.

Heads up, users and press are mistaking this bug as being related to Chrome's proposed <img loading="lazy" /> attribute.

I've reached out to the ZDNet author to clarify that this bug is about using normal front-end development techniques to speed up Firefox's new tab page.

Updated

16 days ago
Summary: Add lazy loading for images → Load new tab pocket article images closer to when they might be shown
(Assignee)

Comment 4

16 days ago

Mark, would you mind unpacking your comment a bit? I'd like to be sure we completely understand your concerns.

Thanks!

Flags: needinfo?(mark)

Comment 5

15 days ago

Gavin, since this bug has been transformed into something I did not think it was about (which would indeed be the loading="lazy" attribute, for lazy-loading images and iframes) I'm not sure if my concerns apply here. This bug was brought up on our forum in tandem with:
https://chromestatus.com/feature/5645767347798016
https://github.com/whatwg/html/issues/2806#issuecomment-378831265
https://addyosmani.com/blog/lazy-loading/

which, as I understand it now, is incorrect.

My main concerns with this are:

  • The more detailed signals to web servers, allowing more detailed tracking of user interaction with the page without JavaScript (has the user scrolled down? if so: how far? etc.)
  • Lack of actual loading of monetization elements if they aren't in view. Many ad services use impressions as a main statistic to pay revenue. This will be severely cut if lazy loading prevents server hits. I don't think that's healthy for the already damaged display ad industry and will push website owners to more intrusive methods of advertising.

As said I'm not sure to what extent this applies to your sponsored content on your new tab page, but even if using normal front-end methods I'd gather similar concerns should be kept in mind.

Flags: needinfo?(mark)

Updated

13 days ago
Status: NEW → RESOLVED
Last Resolved: 13 days ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1531933
You need to log in before you can comment on or make changes to this bug.