Closed Bug 153603 Opened 18 years ago Closed 18 years ago

SYSTEM ENTITY files are not being included.

Categories

(Core :: XML, defect, major)

x86
Windows 2000
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 22942

People

(Reporter: rbt, Assigned: hjtoi-bugzilla)

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1a) Gecko/20020611
BuildID:    2002061104

SYSTEM ENTITY files are not being included.

Reproducible: Always
Steps to Reproduce:
The below XML snippit does not seek out and include "filelist.xml" as I
expected.  Validators say the below is fine, and IE will seek it out.

<?xml version="1.0" encoding="UTF-8"?>
<?xml-stylesheet type="text/xsl" href="docbook-xsl/xhtml/docbook.xsl"?>
<!DOCTYPE book PUBLIC "-//OASIS//DTD DocBook XML V4.1.2//EN"
          "dtd/docbookx.dtd" [

<!ENTITY % filelist SYSTEM "filelist.xml">
%filelist;

]>

Actual Results:  Errors about entities missing.

Expected Results:  Entities from filelist.xml are included.
Duplicate of "Load external DTDs (local and remote) if a pref is set"

Basically, we only load external DTDs if they are living in certain places we
know we can trust....

*** This bug has been marked as a duplicate of 22942 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
QA Contact: petersen → rakeshmishra
You need to log in before you can comment on or make changes to this bug.