Closed Bug 1536209 Opened 5 months ago Closed 5 months ago

Cannot re-request Picture-in-Picture on the same tab (or any other tab in the same content process)

Categories

(Toolkit :: Video/Audio Controls, defect, P1)

defect

Tracking

()

VERIFIED FIXED
mozilla68
Tracking Status
firefox68 --- verified

People

(Reporter: mconley, Assigned: mconley)

References

Details

Attachments

(3 files)

STR:

  1. Ensure that media.videocontrols.picture-in-picture.enabled is set to true
  2. Visit https://www.w3schools.com/html/html5_video.asp
  3. Right-click on the first video, and choose "Picture in Picture" to open the Picture-in-Picture window.
  4. With that window still open, scroll down to the second instance of the same video, and right-click it, choosing "Picture in Picture".

ER:

The original Picture-in-Picture window should close and be replaced with a new one for the new window.

AR:

The original Picture-in-Picture window closes, but a new one isn't opened. The original video also continues to show the "Video is playing in Picture-in-Picture mode" message.

Summary: Cannot re-request Picture-in-Picture on the same tab → Cannot re-request Picture-in-Picture on the same tab (or any other tab in the same content process)
Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0da5718455a7
Add regression test to ensure we can re-request Picture-in-Picture on the same page. r=Felipe
https://hg.mozilla.org/integration/autoland/rev/f82a40540fd1
Make PictureInPictureChild.closePictureInPicture asynchronous and wait for the player window to fully go away. r=Felipe
https://hg.mozilla.org/integration/autoland/rev/eae1fd2ff0c6
Add documentation for PictureInPictureChild, simplify a few things, and clean-up some anonymous functions. r=Felipe

Hello,
Reproduced the issue with Firefox 68.0a1 (20190318213844) on Windows 10 x64, macOS 10.14 and Ubuntu 18.04.
The issue is verified using Firefox 68.0b7 (20190603181408) on Windows 10x64, Ubuntu 18.04 and macOS 10.14.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.