Enable ARM64 Ion in-browser

RESOLVED FIXED in Firefox 67

Status

()

enhancement
P2
normal
RESOLVED FIXED
4 months ago
3 months ago

People

(Reporter: sstangl, Assigned: sstangl)

Tracking

(Depends on 1 bug, Blocks 1 bug)

67 Branch
mozilla68
ARM64
All
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 wontfix, firefox66 wontfix, firefox67 fixed, firefox68+ fixed)

Details

(Whiteboard: [arm64:m2])

Attachments

(1 attachment)

We were asked to wait for 68 to toggle on the pref. 68 is here, toggle away!

Enable IonMonkey on ARM64 in-browser.

Trychooser does not support running any browser tests, as far as I can tell.

\o/ Woot! Ion for ARM64 by default!

Sean, does this patch toggle it for both desktop (Windows) and mobile (Android)?

Flags: needinfo?(sstangl)

(In reply to Mike Conca [:mconca] from comment #3)

Sean, does this patch toggle it for both desktop (Windows) and mobile (Android)?

Yes

Flags: needinfo?(sstangl)
OS: Unspecified → All
Hardware: Unspecified → ARM64
Whiteboard: [arm64:m2]
Pushed by sstangl@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ebf98069b0fb
Enable IonMonkey on ARM64 in-browser. r=nbp
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68

Noticed a bit perf improvement:

== Change summary for alert #19981 (as of Tue, 19 Mar 2019 23:04:07 GMT) ==

Improvements:

16% raptor-speedometer-geckoview android-hw-p2-8-0-android-aarch64 opt 18.24 -> 21.11

For up to date results, see: https://treeherder.mozilla.org/perf.html#/alerts?id=19981

Comment on attachment 9051814 [details]
Bug 1536220 - Enable IonMonkey on ARM64 in-browser. r=nbp

Beta/Release Uplift Approval Request

  • Feature/Bug causing the regression: None
  • User impact if declined: ARM64 will remain disabled on 67. (We've been requested by management to enable it to get better coverage.)
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: Bug 1529559
  • Risk to taking this patch: Medium
  • Why is the change risky/not risky? (and alternatives if risky): The change enables an entire JIT on ARM64, and we expect this to increase the number of crashes. Beta uplift was specifically requested so that we could get broader testing of this feature, because the Android Nightly userbase is extremely small.

The good news is that if this proves too crashy for our tastes, reverting this single patch is sufficient to plug up the issue once more.

  • String changes made/needed:
Attachment #9051814 - Flags: approval-mozilla-beta?

Beta uplift was specifically requested so that we could get broader testing of this feature, because the Android Nightly userbase is extremely small.

Sean, are you proposing we ship ARM64 in Fennec 67 Release or just enable it in Fennec 67 Beta to get more pre-release testing (before shipping in Fennec 68 Release)?

If you want to ship ARM64 builds to Fennec Beta users, Releng will to change their release automation scripts to upload ARM64 Fennec Beta builds to the Google Play Store (like bug 1520261).

Flags: needinfo?(sstangl)

Chris, please check with Steven de Tar, but my understanding is that the plan is to land for release. Based on how it does in Beta, we would back it out if it doesn't fare well, but based on Nightly it's expected to hold up.

Flags: needinfo?(sstangl)

Comment on attachment 9051814 [details]
Bug 1536220 - Enable IonMonkey on ARM64 in-browser. r=nbp

Uplift approved for 67 beta 9.

Attachment #9051814 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.