Closed Bug 1536392 Opened 2 years ago Closed 1 year ago

Perma [tier2] layout/style/test/test_animations_omta.html | transform-like properties on compositor at 5s: should be animating on compositor

Categories

(Core :: CSS Parsing and Computation, defect, P5)

defect

Tracking

()

RESOLVED FIXED
mozilla71
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox69 --- wontfix
firefox70 --- wontfix
firefox71 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: hiro)

References

(Blocks 1 open bug)

Details

(Keywords: intermittent-failure, regression, Whiteboard: [stockwell fixed])

Attachments

(3 files)

#[markdown(off)]
Filed by: ccoroiu [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=234722559&repo=autoland

https://queue.taskcluster.net/v1/task/Ot_rBAuPRsqhIfB8Dj-DAw/runs/0/artifacts/public/logs/live_backing.log

[task 2019-03-19T09:09:50.219Z] 09:09:50 INFO - 1885 INFO TEST-PASS | layout/style/test/test_animations_omta.html | transform-like properties transition runs on compositor thread - got matrix(1, 0, 0, 1, 300, 0), expected matrix(1, 0, 0, 1, 300, 0)
[task 2019-03-19T09:09:50.219Z] 09:09:50 INFO - Buffered messages finished
[task 2019-03-19T09:09:50.219Z] 09:09:50 INFO - 1886 INFO TEST-UNEXPECTED-FAIL | layout/style/test/test_animations_omta.html | transform-like properties on compositor at 5s: should be animating on compositor
[task 2019-03-19T09:09:50.219Z] 09:09:50 INFO - SimpleTest.ok@SimpleTest/SimpleTest.js:275:18
[task 2019-03-19T09:09:50.219Z] 09:09:50 INFO - window.omta_is_approx@layout/style/test/animation_utils.js:487:11
[task 2019-03-19T09:09:50.219Z] 09:09:50 INFO - window[fn]@layout/style/test/test_animations_omta.html:199:19
[task 2019-03-19T09:09:50.219Z] 09:09:50 INFO - window.omta_is@layout/style/test/animation_utils.js:415:12
[task 2019-03-19T09:09:50.219Z] 09:09:50 INFO - window[fn]@layout/style/test/test_animations_omta.html:199:19
[task 2019-03-19T09:09:50.219Z] 09:09:50 INFO - @layout/style/test/test_animations_omta.html:2602:3

Assignee: nobody → boris.chiou
Flags: needinfo?(boris.chiou)

(In reply to Cristina Coroiu [:ccoroiu] from comment #1)

Started to perma fail:
https://treeherder.mozilla.org/#/jobs?repo=autoland&searchStr=android%2C7.0%2Cx86-64%2Copt%2Cmochitests%2Cwith%2Ce10s%2Ctest-android-em-7.0-x86_64%2Fopt-mochitest-e10s-4%2Cm-e10s%284%29&revision=08126c1f53fe82ab685bd3e75e97ce7bf516a3d9&selectedJob=234729442

:boris can you please take a look?

Thanks for notifying me and sorry about this. I'm looking at this right now.

It seems getOMTAStyle(transform) failed if we have a multiple transform-like properties animation and advance it to 50% (i.e. 5s).

I follow the steps from the email in dev-platform to build the Android 7.0 x86_64 opt and run this test with GeckoView (e10s):

  1. Build for Android x86-64 (mozconfig with ac_add_options --target=x86_64)
  2. Run Android: ./mach android-emulator --version x86-7.0
  3. Install the Geckoview androidTest apk
    • ./mach android archive-geckoview
    • ./mach gradle geckoview:installWithGeckoBinariesDebugAndroidTest
    • adb shell pm list packages org.mozilla.package:org.mozilla.geckoview.test
  4. ./mach test layout/style/test/test_animations_omta.html --app=org.mozilla.geckoview.test

Unfortunately, I cannot reproduce this failure on my local machine, and this makes it hard to debug this problem. So I decide to temporary disable this test case (only on GeckoView). (Maybe the steps I followed are not correct.)

If we have an animation with multiple transform-like properties, it
seems getOMTAStyle(transform) returns an empty string at 50% on
Android x86_64 opt with e10s, so we cannot pass this test case. We
temporarily disable this test case on this platform.

Keywords: leave-open
Pushed by apavel@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/993bbf845ef0
Disable multiple transform-like properties animation at 5s on GeckoView. r=hiro

Probably this is somewhat related to bug 1526847.

Whiteboard: [stockwell fixed]

I think now I know the failure reason. The reason is probably that the result transformed position at 5s is outside of the display port. I've pushed a try with tweaking the transform value, let's see the result.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=40d436adcc76d64c6db18a57ff7d23cd883b7420

Assignee: boris.chiou → hikezoe.birchill
Status: NEW → ASSIGNED

Now all test cases for individual transform properties work fine on GeckoView.

Depends on D47200

Pushed by hikezoe.birchill@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8b55e3a5434e
Make the transform transition opposite direction of the translate transition to make sure the transformed results is inside the display port. r=boris
https://hg.mozilla.org/integration/autoland/rev/049de73fed5c
Drop GeckoView checks for individual transform properties cases. r=boris
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Keywords: leave-open
Resolution: --- → FIXED
Target Milestone: --- → mozilla71
You need to log in before you can comment on or make changes to this bug.