Closed Bug 1536427 Opened 2 years ago Closed 2 years ago

Blank Debugger panel when using remote debugging

Categories

(DevTools :: about:debugging, defect, P1)

defect

Tracking

(firefox-esr60 unaffected, firefox66 unaffected, firefox67 verified, firefox68 verified)

VERIFIED FIXED
Firefox 68
Tracking Status
firefox-esr60 --- unaffected
firefox66 --- unaffected
firefox67 --- verified
firefox68 --- verified

People

(Reporter: jdescottes, Assigned: jdescottes)

References

(Blocks 1 open bug)

Details

(Keywords: regression, Whiteboard: [remote-debugging-reserve][qa-triaged])

Attachments

(1 file)

Spotted in Bug 1533729

Similar symptoms to Bug 1530861. The debugger panel is completely blank when debugging Fx 66 from Fx 67 or newer. Probably a new regression that happened just before the merge, since the debugger was working 2 weeks ago when we fixed 1530861.

STRs:

ER: Debugger UI should be displayed
AR: Debugger UI is blank

Alex, Jason, any idea what could have triggered this?

The error is

error: "unrecognizedPacketType"
​
from: "server1.conn2.child8/context71"
​
message: "Actor server1.conn2.child8/context71 does not recognize the packet type pauseOnExceptions"
Flags: needinfo?(poirot.alex)
Flags: needinfo?(jlaster)

Julian, we recently switched how pause on exceptions are set on the server. It used to be part of the resume packet. https://bugzilla.mozilla.org/show_bug.cgi?id=1532791

Flags: needinfo?(jlaster)

Thanks! And thanks for walking through the diff with me, I'll try to put a patch up for review.

Flags: needinfo?(poirot.alex)
Assignee: nobody → jdescottes
Status: NEW → ASSIGNED

Could not spot any regression related to removing the call to loadOnPrefs. I did find a small issue with pause on exceptions, but it seems it's not a regression. Filed https://github.com/firefox-devtools/debugger/issues/8143 for it.

Blocks: 1532791
Priority: -- → P1
Whiteboard: [remote-debugging-reserve]
Pushed by jdescottes@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6a35904d1c1d
Stop calling actions.pauseOnExceptions on Debugger startup;r=jlast
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68

ni? to uplift this after some time on Nightly

Flags: needinfo?(jdescottes)

Verified as fixed on Firefox Nightly 68.0a1 on Windows 10 x 64, Mac OS X 10.14 and on Ubuntu 16.04 x64.
I confirm that the debugger panel isn't blank anymore when debugging Fx66 from Fx67 or newer.

Comment on attachment 9052211 [details]
Bug 1536427 - Stop calling actions.pauseOnExceptions on Debugger startup;r=jlast

Beta/Release Uplift Approval Request

  • Feature/Bug causing the regression: Bug 1532791
  • User impact if declined: Users cannot use the Debugger when remote debugging Fx 66 from DevEdition 67
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: See STRs in summary.
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Simple javascript fix, devtools only, no issue raised on Nightly since the fix landed.
  • String changes made/needed:
Flags: needinfo?(jdescottes)
Attachment #9052211 - Flags: approval-mozilla-beta?
Flags: qe-verify?

Since this bug has steps for QA, updating the qe-verify flag.

Flags: qe-verify? → qe-verify+
Whiteboard: [remote-debugging-reserve] → [remote-debugging-reserve][qa-triaged]
QA Contact: hani.yacoub
Keywords: regression

Comment on attachment 9052211 [details]
Bug 1536427 - Stop calling actions.pauseOnExceptions on Debugger startup;r=jlast

Safe fix for a 67 devtools regression, fix verified on Nightly and baked there for a week, uplift approved for 67 beta 6, thanks.

Attachment #9052211 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Duplicate of this bug: 1533729

Verified as fixed on Firefox 67.0b6 on Windows 10 x 64, Mac OS X 10.14 and on Ubuntu 16.04 x64.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
See Also: → 1544813
You need to log in before you can comment on or make changes to this bug.