TypeError: this.populateSendTabToDevicesMenu is not a function when opening "send tab to device" early enough on startup (no sync has happened yet)

VERIFIED FIXED in Firefox 67

Status

()

defect
VERIFIED FIXED
4 months ago
3 months ago

People

(Reporter: Gijs, Assigned: vbudhram)

Tracking

67 Branch
Firefox 68
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox67 verified, firefox68 verified)

Details

Attachments

(1 attachment)

The callback situation here presumably means this is no longer bound correctly.

STR:

  1. enable session restore
  2. sign into sync
  3. ensure there's another device in your sync account
  4. open a page you can "send to device"
  5. restart
  6. quickly open the account menu, click "send tab to device"

ER:

Initially it displays "Syncing devices..." and then it shows the devices

AR:
it never shows devices until you close and reopen.

Assignee: nobody → vbudhram
Attachment #9052066 - Attachment description: Bug 1536467 - Use gSync instead of this for Send Tab to Device → Bug 1536467 - bind callbacks to `this` for Send Tab to Device subview so they work when we're waiting for the initial sync
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/4dedf93bfe2d
bind callbacks to `this` for Send Tab to Device subview so they work when we're waiting for the initial sync r=Gijs
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68

I’ve reproduced this issue on Nightly 68.0a1 (2019-03-18) with Windows 10 x64.
The issue is verified fixed on Nightly 68.0a1 (2019-04-08) and Beta 67.0b9 with Windows 10 x64, macOS 10.13 and Ubuntu 18.04 x64.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.