Closed Bug 1536816 Opened 8 months ago Closed 5 months ago

Rename UrlbarInput::handleCommand or remove the TODO comment

Categories

(Firefox :: Address Bar, task, P3)

task
Points:
1

Tracking

()

RESOLVED FIXED
Firefox 69
Tracking Status
firefox68 --- fixed
firefox69 --- fixed

People

(Reporter: standard8, Assigned: okonaraddi)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Currently at the start of UrlbarInput::handleCommand we have:

   * Handles an event which would cause a url or text to be opened.
   * TODO Bug <this bug> the name is currently handleCommand which is compatible with
   * urlbarBindings. However, it is no longer called automatically by autocomplete,
   * See _on_keydown.

We should either rename this to something better, or remove the todo comment. Suggestions welcome.

Priority: -- → P5

Gonna up the priority because P5 is almost wontfix and we should find a resolution here. Also marking Task. (By definition tasks have low user impact, and making all tasks P5s seems a bit silly.)

Type: enhancement → task
Priority: P5 → P3
Blocks: 1551227
No longer blocks: quantumbar
Points: --- → 1

Note there are some tests that call gURLBar.handleCommand(): https://searchfox.org/mozilla-central/search?q=handleCommand&case=false&regexp=false&path=browser%2Fcomponents%2Furlbar

Which are right now:

  • browser/components/urlbar/tests/browser/Panel.jsm
  • browser/components/urlbar/tests/browser/browser_stop_pending.js
  • browser/components/urlbar/tests/browser/browser_urlbarStop.js

Panel.jsm is only used by a legacy test, but the other two run on quantumbar. So it would probably be easier/better to just leave the name as handleCommand and remove the TODO.

I'm not sure what a better name would be anyway. "handleEvent" might be better since its first parameter is an event, but there's already another handleEvent method on UrlbarInput.

Assignee: nobody → okonaraddi
Status: NEW → ASSIGNED
Pushed by dwillcoxon@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/932c92001df0
Remove the TODO comment in UrlbarInput::handleCommand. r=adw

Comment on attachment 9069760 [details]
Bug 1536816 - Remove the TODO comment in UrlbarInput::handleCommand. r=adw!

Beta/Release Uplift Approval Request

  • User impact if declined: No user impact, could potentially avoid conflicts with future quantumbar uplifts
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce: n/a
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Only removing a comment
  • String changes made/needed:
Attachment #9069760 - Flags: approval-mozilla-beta?
Flags: qe-verify-
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 69

Comment on attachment 9069760 [details]
Bug 1536816 - Remove the TODO comment in UrlbarInput::handleCommand. r=adw!

comments change, effectively a no-op, approved for 68.0b8

Attachment #9069760 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.