Closed Bug 15369 Opened 21 years ago Closed 21 years ago

Crash clicking Back and Forward consecutively

Categories

(Core :: Layout: Form Controls, defect, P3)

defect

Tracking

()

VERIFIED DUPLICATE of bug 15253

People

(Reporter: blee, Assigned: radha)

References

()

Details

To reproduce,
Launch Apprunner and type in the URL above to load the JA home page.
Click Back (to Mozilla.org) and Back to the page of typed-in URL.
==> Apprunner crashs. Stack Trace info at http://babel/stacktrace/14018526.htm.

So far, this seems to happen only with pages with double byte meta charset tag.
Observed in Win 32 10-01-09-M11 bld.
QA Contact: teruko → blee
Summary: [PP] Clicking Back and Forward consecutively quits Apprunner → [PP] Crash clicking Back and Forward consecutively
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
*** This bug has been marked as a duplicate of 14967 ***
Status: RESOLVED → REOPENED
Status: REOPENED → NEW
Resolution: DUPLICATE → ---
Re-opening as this happens under different circumstances.
Talk to blee and he made a typo in his origional description. It should be -

Click Back (to Mozilla.org) and FORWARD to the page of typed-in URL.
He said it crash afte the click of FORWARD
Assignee: ftang → pollmann
The stack trace in http://babel/stacktrace/14018526.htm show the following

Call Stack:    (Signature = PL_HashTableRawLookup 8459eae0)

   PL_HashTableRawLookup
                                  [plhash.c, line 180]

   PL_HashTableLookup
                                  [plhash.c, line 345]

   nsHashtable::Get

[d:\builds\seamonkey\mozilla\xpcom\ds\nsHashtable.cpp, line 166]

   nsSupportsHashtable::Get

[d:\builds\seamonkey\mozilla\xpcom\ds\nsHashtable.cpp, line 404]

   nsLayoutHistoryState::GetState

[d:\builds\seamonkey\mozilla\layout\base\src\nsLayoutHistoryState.cpp, line 130]

Reassign this to pollmann since his name show in cvblame of
nsLayoutHistoryState.cpp, line 130. Add radha to the cc list
Assignee: pollmann → radha
Radha, I was able to reproduce this bug as described.  My stack trace was the
one we have been seeing with bug 14967 and bug 15253  As such, I'm reassigning
it to you.

(gdb) bt
#0  0x11003a in ?? ()
#1  0x40caef45 in FrameManager::RestoreFrameState (this=0x825a9f0,
aFrame=0x8a03148, aState=0x8b25fe0) at nsFrameManager.cpp:1130
#2  0x40caeee4 in FrameManager::RestoreFrameState (this=0x825a9f0,
aFrame=0x8839108, aState=0x8b25fe0) at nsFrameManager.cpp:1123
#3  0x40caeee4 in FrameManager::RestoreFrameState (this=0x825a9f0,
aFrame=0x89dfc28, aState=0x8b25fe0) at nsFrameManager.cpp:1123
#4  0x40caeee4 in FrameManager::RestoreFrameState (this=0x825a9f0,
aFrame=0x89dff80, aState=0x8b25fe0) at nsFrameManager.cpp:1123
#5  0x40caef45 in FrameManager::RestoreFrameState (this=0x825a9f0,
aFrame=0x8ae49e0, aState=0x8b25fe0) at nsFrameManager.cpp:1130
#6  0x40caeee4 in FrameManager::RestoreFrameState (this=0x825a9f0,
aFrame=0x8ae8360, aState=0x8b25fe0) at nsFrameManager.cpp:1123
#7  0x40caeee4 in FrameManager::RestoreFrameState (this=0x825a9f0,
aFrame=0x86dd810, aState=0x8b25fe0) at nsFrameManager.cpp:1123
#8  0x40caeee4 in FrameManager::RestoreFrameState (this=0x825a9f0,
aFrame=0x86dd7b0, aState=0x8b25fe0) at nsFrameManager.cpp:1123
#9  0x40caef45 in FrameManager::RestoreFrameState (this=0x825a9f0,
aFrame=0x8abe860, aState=0x8b25fe0) at nsFrameManager.cpp:1130
#10 0x40caef45 in FrameManager::RestoreFrameState (this=0x825a9f0,
aFrame=0x86dd6a0, aState=0x8b25fe0) at nsFrameManager.cpp:1130
#11 0x40caef45 in FrameManager::RestoreFrameState (this=0x825a9f0,
aFrame=0x8ae8318, aState=0x8b25fe0) at nsFrameManager.cpp:1130
#12 0x40caeee4 in FrameManager::RestoreFrameState (this=0x825a9f0,
aFrame=0x8ae8230, aState=0x8b25fe0) at nsFrameManager.cpp:1123
#13 0x40caef45 in FrameManager::RestoreFrameState (this=0x825a9f0,
aFrame=0x8758530, aState=0x8b25fe0) at nsFrameManager.cpp:1130
#14 0x40caef45 in FrameManager::RestoreFrameState (this=0x825a9f0,
aFrame=0x8ade5b0, aState=0x8b25fe0) at nsFrameManager.cpp:1130
#15 0x40caeee4 in FrameManager::RestoreFrameState (this=0x825a9f0,
aFrame=0x8af4010, aState=0x8b25fe0) at nsFrameManager.cpp:1123
#16 0x40cd3b17 in PresShell::ContentAppended (this=0x825a920,
aDocument=0x89ea958, aContainer=0x881d2c4, aNewIndexInContainer=2) at
nsPresShell.cpp:1731
#17 0x40e8f907 in nsDocument::ContentAppended (this=0x89ea958,
aContainer=0x881d2c4, aNewIndexInContainer=2) at nsDocument.cpp:1571
#18 0x40d81840 in nsHTMLDocument::ContentAppended (this=0x89ea958,
aContainer=0x881d2c4, aNewIndexInContainer=2) at nsHTMLDocument.cpp:1040
#19 0x40d7cdf1 in HTMLContentSink::NotifyBody (this=0x8857368) at
nsHTMLContentSink.cpp:276
#20 0x40d76ef0 in HTMLContentSink::DidBuildModel (this=0x8857368,
aQualityLevel=0) at nsHTMLContentSink.cpp:1814
#21 0x410267ff in CNavDTD::DidBuildModel (this=0x8709218, anErrorCode=0,
aNotifySink=1, aParser=0x8b27ff0, aSink=0x8857368) at CNavDTD.cpp:525
#22 0x410339f6 in nsParser::DidBuildModel (this=0x8b27ff0, anErrorCode=0) at
nsParser.cpp:547
#23 0x41034692 in nsParser::ResumeParse (this=0x8b27ff0, aDefaultDTD=0x0,
aIsFinalChunk=0) at nsParser.cpp:936
#24 0x4103514a in nsParser::OnDataAvailable (this=0x8b27ff0, channel=0x89ead28,
aContext=0x0, pIStream=0x89bda20, sourceOffset=0, aLength=8059) at
nsParser.cpp:1356
#25 0x4097bb0d in nsDocumentBindInfo::OnDataAvailable (this=0x89dcd80,
channel=0x89ead28, ctxt=0x0, aStream=0x89bda20, sourceOffset=0, aLength=8059) at
nsDocLoader.cpp:1371
#26 0x4097c73c in nsChannelListener::OnDataAvailable (this=0x89e08b8,
aChannel=0x89ead28, aContext=0x0, aInStream=0x89bda20, aOffset=0, aCount=8059)
at nsDocLoader.cpp:1612
#27 0x4097c73c in nsChannelListener::OnDataAvailable (this=0x89ebaf8,
aChannel=0x89ead28, aContext=0x0, aInStream=0x89bda20, aOffset=0, aCount=8059)
at nsDocLoader.cpp:1612
#28 0x413bc03f in nsHTTPResponseListener::OnDataAvailable (this=0x89eb418,
channel=0x886ea90, context=0x89ead28, i_pStream=0x89bda20, i_SourceOffset=0,
i_Length=8059) at nsHTTPResponseListener.cpp:186
#29 0x409176a6 in nsOnDataAvailableEvent::HandleEvent (this=0x41402df0) at
nsAsyncStreamListener.cpp:358
#30 0x40916e8a in nsStreamListenerEvent::HandlePLEvent (aEvent=0x41402e18) at
nsAsyncStreamListener.cpp:152
#31 0x4018f2bb in ?? () from /build/ng/mozilla/dist/bin/libplds3.so
#32 0x4018f1cc in ?? () from /build/ng/mozilla/dist/bin/libplds3.so
#33 0x4015308d in ?? () from /build/ng/mozilla/dist/bin/libxpcom.so
#34 0x4051d5d6 in ?? () from /build/ng/mozilla/dist/bin/libwidget_gtk.so
#35 0x4068fd7b in ?? () from /usr/lib/libgdk-1.2.so.0
#36 0x406ba3ca in ?? () from /usr/lib/libglib-1.2.so.0
#37 0x406bba86 in ?? () from /usr/lib/libglib-1.2.so.0
#38 0x406bc041 in ?? () from /usr/lib/libglib-1.2.so.0
#39 0x406bc1e1 in ?? () from /usr/lib/libglib-1.2.so.0
#40 0x405e87a9 in ?? () from /usr/lib/libgtk-1.2.so.0
#41 0x4051dda9 in ?? () from /build/ng/mozilla/dist/bin/libwidget_gtk.so
#42 0x40396ee1 in ?? () from /build/ng/mozilla/dist/bin/libnsappshell.so
#43 0x804b4d7 in main1 (argc=1, argv=0xbffffa34) at nsAppRunner.cpp:591
#44 0x804b759 in main (argc=1, argv=0xbffffa34) at nsAppRunner.cpp:702
#45 0x4029014b in ?? () from /lib/libc.so.6
Component: Internationalization → HTML Form Controls
OS: Windows NT → All
Hardware: PC → All
We need a 'Session History' Component.  :)
Status: NEW → ASSIGNED
Target Milestone: M11
Summary: [PP] Crash clicking Back and Forward consecutively → Crash clicking Back and Forward consecutively
This also happens in Linux 10-07-16-M10 bld.
Status: ASSIGNED → RESOLVED
Closed: 21 years ago21 years ago
Resolution: --- → DUPLICATE
*** This bug has been marked as a duplicate of 15253 ***
Status: RESOLVED → VERIFIED
Verified dup.
You need to log in before you can comment on or make changes to this bug.