anchor markup between rows splits table

VERIFIED FIXED

Status

Core Graveyard
Viewer App
P2
major
VERIFIED FIXED
19 years ago
9 years ago

People

(Reporter: Eli Goldberg, Assigned: rickg)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
Using 11.23.98 build (XPViewer) on Win32 (Win98 & NT 4 checked), the table
structure does not render properly.

There's too much to describe verbally, but some of the details are:

* The "Departments" table column ends prematurely after "Small Business", and
with the remaining items (Retirement ---> Financial Forums) continued in a third
column, to the right of where they should be. (rather than continued as a single
list in the left-most column of the table)

* Much of the rest of the page is presented as a single table column (middle
row), and lacks the intended 3-column structure that the remainder of the page
is supposed to have.
(Assignee)

Updated

19 years ago
Assignee: rickg → buster

Updated

19 years ago
Status: NEW → ASSIGNED

Updated

19 years ago
Summary: quicken.com root page's table is vertically elongated → ss:quicken.com root page's table is vertically elongated

Comment 1

19 years ago
Putting on ss: radar

Updated

19 years ago
Assignee: buster → rickg
Severity: normal → major
Status: ASSIGNED → NEW
Priority: P3 → P2
Summary: ss:quicken.com root page's table is vertically elongated → ss: anchor markup between rows splits table

Comment 2

19 years ago
changed summary to reflect the root cause of the problem
the problem is markup between </tr><tr> in a table is causing the second row to
get jettisoned from the table.  Minimized test case below.  If you change <a> to
<x>, the problem goes away.

<table bgcolor=yellow>
  <tr>
    <td>
      cell 1
    </td>
  </tr>
  <a></a>
  <tr>
    <td>
      cell 2
    </td>
  </tr>
</table>
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED

Comment 3

19 years ago
*** Bug 1620 has been marked as a duplicate of this bug. ***

Updated

19 years ago
Summary: ss: anchor markup between rows splits table → anchor markup between rows splits table

Comment 4

19 years ago
Taking off ss: list per bug mtg today.
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 5

19 years ago
Verified fixed on 1.12.99 Win32 and 1.13.99 Mac OS builds. (1.12.99 & 1.13.99
builds on Linux won't view any URLs specified.)

Specifically:

- The quicken.com page lays out correctly on both platforms
- The HTML test case lays out on both platforms. (both cells are yellow)
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.