saving page as crashes when file as western european accents

VERIFIED DUPLICATE of bug 132905

Status

Core Graveyard
File Handling
--
critical
VERIFIED DUPLICATE of bug 132905
16 years ago
2 years ago

People

(Reporter: andrelourenco, Assigned: Bill Law)

Tracking

({crash, stackwanted})

Trunk
x86
Linux
crash, stackwanted

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0+) Gecko/20020525
BuildID:    2002052507

saving a page as: page name is something like this: andré.gif

Reproducible: Always
Steps to Reproduce:
1.open a web page with an image that as an á or í or ó ... in its name
2.view image
3.save page as

Actual Results:  crash report shows up

Expected Results:  expected that mozilla would save that image

if i change the name in "save as" to andre.gif (note that on the example i gave
the name was andré.gif) mozilla do not crashes!

Comment 1

16 years ago
similar: bug 153093
-> file handling

Reporter: If you have talkback IDs for these crashes, please include.
Assignee: Matti99 → law
Component: Browser-General → File Handling
QA Contact: imajes-qa → sairuh

Comment 2

16 years ago
wfm using build 2002062304 on Win2k and build 2002062106 on Linux (trunk).
Reporter, do you get a Talkback window popup when crashing ? If so, please post
Talkback ID for this crash by running 'mozilla/bin/components/talkback/talkback'.
Keywords: crash, stackwanted

Comment 3

16 years ago
Could reproduce Win98 2002062308
Talkback: TB7654489Z
To reproduce:
1. File/Save page as
2. give a filename with special chars tested with é and ö
3. => crash
(Reporter)

Comment 4

16 years ago
I am the reporter. Unfortunately I知 far away from home now, so I will only be
able to post the talkback ID next weekend. 
BTW, it doesn't crash on mozilla 1.0 for windows 2000: 2002053012
Dup based on the stack in that talkback:

nsAssignmentSet::GetAssignmentFor
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsRuleNetwork.cpp, line 596]
nsTemplateMatch::GetAssignmentFor
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsTemplateMatch.cpp, line 52]
nsXULTemplateBuilder::SubstituteTextReplaceVariable
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULTemplateBuilder.cpp,
line 1168]
nsXULTemplateBuilder::ParseAttribute
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULTemplateBuilder.cpp,
line 1077]
nsXULTemplateBuilder::SubstituteText
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULTemplateBuilder.cpp,
line 1125]
nsXULContentBuilder::BuildContentFromTemplate
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULContentBuilder.cpp,
line 783]
nsXULContentBuilder::CreateTemplateContents
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULContentBuilder.cpp,
line 1385]
nsXULContentBuilder::CreateTemplateAndContainerContents
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULContentBuilder.cpp,
line 1209]
nsXULContentBuilder::CreateContents
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULContentBuilder.cpp,
line 1765]
nsXULElement::EnsureContentsGenerated
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp, line 3654]
nsXULElement::ChildCount
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp, line 2175]
nsXULElement::GetChildNodes
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp, line 768]
nsXULElement::GetElementsByTagName
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp, line 3684]
nsXULElement::GetElementsByTagName
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp, line 3718]
nsXULElement::GetElementsByTagName
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp, line 3718]
nsXULElement::GetElementsByTagName
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp, line 3718]
nsXULElement::GetElementsByTagName
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp, line 1425]
XPTC_InvokeByIndex
[c:/builds/seamonkey/mozilla/xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp,
line 106]
XPCWrappedNative::CallMethod
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappednative.cpp, line 1996]
XPC_WN_CallMethod
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp,
line 1267]
js_Invoke [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 790]
js_Interpret [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 2744]
js_Invoke [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 806]
js_InternalInvoke [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 881]
JS_CallFunctionValue [c:/builds/seamonkey/mozilla/js/src/jsapi.c, line 3430]
nsJSContext::CallEventHandler
[c:/builds/seamonkey/mozilla/dom/src/base/nsJSEnvironment.cpp, line 1045]
nsJSEventListener::HandleEvent
[c:/builds/seamonkey/mozilla/dom/src/events/nsJSEventListener.cpp, line 184]
nsXBLPrototypeHandler::ExecuteHandler
[c:/builds/seamonkey/mozilla/content/xbl/src/nsXBLPrototypeHandler.cpp, line 457]
nsXBLPrototypeHandler::BindingAttached
[c:/builds/seamonkey/mozilla/content/xbl/src/nsXBLPrototypeHandler.cpp, line 505]
nsXBLPrototypeBinding::BindingAttached
[c:/builds/seamonkey/mozilla/content/xbl/src/nsXBLPrototypeBinding.cpp, line 441]
nsXBLBinding::ExecuteAttachedHandler
[c:/builds/seamonkey/mozilla/content/xbl/src/nsXBLBinding.cpp, line 1040]
nsBindingManager::ProcessAttachedQueue
[c:/builds/seamonkey/mozilla/content/xbl/src/nsBindingManager.cpp, line 913]
nsCSSFrameConstructor::ContentInserted
[c:/builds/seamonkey/mozilla/layout/html/style/src/nsCSSFrameConstructor.cpp,
line 9158]
nsCSSFrameConstructor::ContentAppended
[c:/builds/seamonkey/mozilla/layout/html/style/src/nsCSSFrameConstructor.cpp,
line 8318]
StyleSetImpl::ContentAppended
[c:/builds/seamonkey/mozilla/content/base/src/nsStyleSet.cpp, line 1527]
PresShell::ContentAppended
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp, line 5315]
nsXULDocument::ContentAppended
[c:/builds/seamonkey/mozilla/content/xul/document/src/nsXULDocument.cpp, line 2256]
nsXULContentBuilder::Rebuild
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULContentBuilder.cpp,
line 1744]
nsXULContentBuilder::Rebuild
[c:/builds/seamonkey/mozilla/content/xul/templates/src/nsXULContentBuilder.cpp,
line 1753]
XPTC_InvokeByIndex
[c:/builds/seamonkey/mozilla/xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp,
line 106]
XPCWrappedNative::CallMethod
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappednative.cpp, line 1996]
XPC_WN_CallMethod
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp,
line 1267]
js_Invoke [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 790]
js_Interpret [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 2744]
js_Invoke [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 806]
js_InternalInvoke [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 881]
JS_CallFunctionValue [c:/builds/seamonkey/mozilla/js/src/jsapi.c, line 3430]
nsJSContext::CallEventHandler
[c:/builds/seamonkey/mozilla/dom/src/base/nsJSEnvironment.cpp, line 1045]
nsJSEventListener::HandleEvent
[c:/builds/seamonkey/mozilla/dom/src/events/nsJSEventListener.cpp, line 184]
nsEventListenerManager::HandleEventSubType
[c:/builds/seamonkey/mozilla/content/events/src/nsEventListenerManager.cpp, line
1222]
nsEventListenerManager::HandleEvent
[c:/builds/seamonkey/mozilla/content/events/src/nsEventListenerManager.cpp, line
1904]
GlobalWindowImpl::HandleDOMEvent
[c:/builds/seamonkey/mozilla/dom/src/base/nsGlobalWindow.cpp, line 740]
DocumentViewerImpl::LoadComplete
[c:/builds/seamonkey/mozilla/content/base/src/nsDocumentViewer.cpp, line 1544]
nsDocShell::EndPageLoad
[c:/builds/seamonkey/mozilla/docshell/base/nsDocShell.cpp, line 3954]
nsWebShell::EndPageLoad
[c:/builds/seamonkey/mozilla/docshell/base/nsWebShell.cpp, line 731]
nsDocShell::OnStateChange
[c:/builds/seamonkey/mozilla/docshell/base/nsDocShell.cpp, line 3868]
nsDocLoaderImpl::FireOnStateChange
[c:/builds/seamonkey/mozilla/uriloader/base/nsDocLoader.cpp, line 1175]
nsDocLoaderImpl::doStopDocumentLoad
[c:/builds/seamonkey/mozilla/uriloader/base/nsDocLoader.cpp, line 834]
nsDocLoaderImpl::DocLoaderIsEmpty
[c:/builds/seamonkey/mozilla/uriloader/base/nsDocLoader.cpp, line 732]
nsDocLoaderImpl::OnStopRequest
[c:/builds/seamonkey/mozilla/uriloader/base/nsDocLoader.cpp, line 663]
nsLoadGroup::RemoveRequest
[c:/builds/seamonkey/mozilla/netwerk/base/src/nsLoadGroup.cpp, line 537]
nsCachedChromeChannel::HandleStopLoadEvent
[c:/builds/seamonkey/mozilla/rdf/chrome/src/nsChromeProtocolHandler.cpp, line 481]
PL_HandleEvent [c:/builds/seamonkey/mozilla/xpcom/threads/plevent.c, line 597]
_md_EventReceiverProc [c:/builds/seamonkey/mozilla/xpcom/threads/plevent.c, line
1078] 

*** This bug has been marked as a duplicate of 132905 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 6

16 years ago
here they are:

tb7628671q
tb7628636y
tb7628584e
tb7628458x
marking verified as a duplicate.

if you decide to reopen this bug, please clarify why.

search string for bugspam removal: SalviaGuaranitica
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.