Closed Bug 1537613 Opened 1 year ago Closed 1 year ago

[python3] Check dependencies and update them to versions compatible with Python 3.6

Categories

(Webtools :: Pontoon, defect, P3)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: jotes, Assigned: jotes)

References

Details

Attachments

(1 file)

Some of dependencies don't support Python 3:

I see two action items:

  • Update Silme to the version with support for Python 3 and test it on staging
  • Move Mercurial and its dependencies to a separate requirements file and update installation scripts and docs

:mathjazz How can I help you with Silme? I can test Emin's patch on my machine and then notify you to give it a try on the staging.

(In reply to Jarek Śmiejczak [:jotes] from comment #0)

:mathjazz How can I help you with Silme? I can test Emin's patch on my machine and then notify you to give it a try on the staging.

That would be great. Once the PR is ready, I can run a few tests on stage again (as I did when the silme patch was being developed).

Priority: -- → P3
Assignee: nobody → poke
Status: NEW → ASSIGNED
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.