LWT-static theme migration not working on Fennec

VERIFIED FIXED in Firefox 67

Status

()

defect
P1
normal
VERIFIED FIXED
5 months ago
4 months ago

People

(Reporter: amoga, Assigned: aswan)

Tracking

Trunk
Firefox 68
Points:
---

Firefox Tracking Flags

(firefox67 verified, firefox68 verified)

Details

Attachments

(1 attachment)

User Agent: Mozilla/5.0 (Android 8.0.0; Mobile; rv:68.0) Gecko/68.0 Firefox/68.0

[Prerequisites]:

  • xpinstall.signatures.dev-root = true
  • xpinstall.signatures.required = false

Not sure if the following prefs have an impact, since they are handling webextension updates, but I've configured them anyway:

  • extensions.update.url - versioncheck points to -dev
  • extensions.update.background.url - versioncheck points to -dev
  • extensions.update.interval - 1
  • extensions.autoupdate.interval - 1

[STR]:

  1. Install a LWT on AMO -dev
    • I have the following example set in lightweightThemes.usedThemes:
[{"id":"60179","name":"little flowers","headerURL":"https://addons-dev-cdn.allizom.org/user-media/addons/60179/dupa.jpg?modified=1353156254","iconURL":"https://addons-dev-cdn.allizom.org/user-media/addons/60179/preview_small.jpg?modified=1353156254","previewURL":"https://addons-dev-cdn.allizom.org/user-media/addons/60179/preview_large.jpg?modified=1353156254","author":"bluszcz","updateURL":"https://versioncheck-dev.allizom.org/en-US/themes/update-check/60179","version":"1.0"}]
  1. Restart your browser
  2. Go to about:addons and check if the migrated version of the installed LWT is available

[Actual result]:

  • the LWT theme hasn't been updated

[Expected result]:

[Notes]:

Priority: -- → P1

It looks like we're bailing out here:
https://searchfox.org/mozilla-central/rev/a7315d78417179b151fef6108f2bce14786ba64d/toolkit/mozapps/extensions/LightweightThemeManager.jsm#369-370

Since the preference lightweightThemes.update.enabled is not set on fennec

Summary: /themes/update-check/ is not working on Android → LWT-static theme migration not working on Fennec

I'm having trouble with my local emulator setup. Can we get some help from QA: try setting the preference lightweightThemes.updated.enabled manually from about:config and then repeating the test?

If that works (and I expect it might) then that's a pretty simple fix that we should uplift right away.
If that doesn't work, gathering device logs with "adb logcat" and attaching them here would be helpful.

Flags: needinfo?(amoga)

Also ensure that LightweightThemeManager.updateOneTheme() returns
even if the update request fails.

Setting the preference lightweightThemes.update.enabled in about config did the trick. I can confirm that updates are working with Android 8.0, on latest Nightly, Beta 67.0b5 and Firefox release.

Pushed by aswan@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d1e03f3bba1a
Enable LWT updates on Android r=mixedpuppy
Assignee: nobody → aswan
Flags: needinfo?(amoga)

Comment on attachment 9053750 [details]
Bug 1537723 Enable LWT updates on Android

Beta/Release Uplift Approval Request

  • Feature/Bug causing the regression: not a regression
  • User impact if declined: Fennec users of lightweight themes will not be updated to the new theme format, and they will lose their themes in Firefox 68 due to bug 1525762
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Theme updates happened uneventfully on desktop last week. This patch just flips a pref to cause the same thing to happen on Fennec.
  • String changes made/needed: none
Attachment #9053750 - Flags: approval-mozilla-beta?
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68

We have STR so let's have QA check with the next nightly that this is fixed and we can then uplift for the next Fennec beta (beta 7). Thanks.

Flags: qe-verify+
QA Whiteboard: [qa-triaged]

Ni on Stefan to verify this on latest Nightly.

Flags: needinfo?(stefan.deiac)

Hi, I tested this issue on the latest version of Nightly 68.0a1 (2019-03-29) following the steps from comment 0 and I wasn't able de reproduce the problem.

Device:

  • Samsung Galaxy Tab S3 (Android 8.0);

Alexandra, can you double check to be sure that the issue it's fixed?
Thanks.

QA Whiteboard: [qa-triaged]
Flags: qe-verify+
Flags: needinfo?(stefan.deiac)
Flags: needinfo?(amoga)

Verified fixed on Nightly 68.0a1 Build ID 20190329094433 with Android 8.0. lightweightThemes.update.enabled pref is enabled by default and LWT update checks are running.

Flags: needinfo?(amoga)

Due to comment 11 and my findings, I'll make this issue as verified, thanks.

Status: RESOLVED → VERIFIED

Comment on attachment 9053750 [details]
Bug 1537723 Enable LWT updates on Android

Low risk patch, verified by QA on Nightly, approved for 67 beta 7, thanks.

Attachment #9053750 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Verified as fixed on Beta 67.0b7 build with Android 6.0.1.

You need to log in before you can comment on or make changes to this bug.