Closed Bug 1538025 Opened 3 years ago Closed 3 years ago

DevTools ADB Extension forces itself to be allowed in private windows (won't let you disallow it)

Categories

(WebExtensions :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1533150

People

(Reporter: dholbert, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Attached video screencast of bug

(I also filed this as https://github.com/mozilla/devtools-adb-extension/issues/17 because I'm not sure if it's a bug in the extension itself or a bug in Firefox Nightly. Please feel free to close one or the other as-needed, once the true culprit is identified.)

STR:

  1. Install Firefox DevTools ADB Extension in Firefox Nightly (by visiting Tools | Web Developer | WebIDE -- this causes the extension to suddenly appear in your list of installed addons).

  2. In a new tab, visit about:addons and click "extensions"
    --> Note that Firefox DevTools ADB Extension is tagged as ALLOWED IN PRIVATE WINDOWS

  3. Click the addon to view its settings, and try to click radio button labeled...
    "Run in Private Windows: ... [] Don't allow"

EXPECTED RESULTS: Click should be honored, "Don't Allow" should be selected.
ACTUAL RESULTS: "Don't Allow" is only selected very briefly, and then "Allow" becomes selected again.

There doesn't seem to be any way to select "Don't Allow". You can get it selected for slightly longer if you Disable the addon and then pick Don't Allow while it's disabled, but once you reenable it, then "Allow" becomes selected on your next (re)-load of about:addons.

I'm using Firefox Nightly 68.0a1 (2019-03-21) (64-bit)

Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1533150
You need to log in before you can comment on or make changes to this bug.