Closed Bug 1538027 Opened 10 months ago Closed 9 months ago

submit and input file buttons are not translated to the locale language

Categories

(Core :: Localization, defect)

66 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1537704

People

(Reporter: mister.freeman, Unassigned)

Details

Attachments

(1 file)

Attached file test_submit.html

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:66.0) Gecko/20100101 Firefox/66.0

Steps to reproduce:

I use the archlinux package of firefox 66,
I created a html page test, with a form and a submit button with no label

<form method='POST'>
<label>Bug language</label>
<input type="submit" />
</form>

see the attached file for the html source code

Actual results:

the submit button is displayed in firefox 66 with the english name ("submit"), instead of the french name "valider" (I configured firefox to use french for web pages)

Expected results:

the submit button should be displayed in french ("valider"),

if I run the same html file in chromium and opera then the correct name in french is displayed for the submit button, so it's probably a bug inside the source code of firefox, or in the official french translation file for firefox 66

the bug occurs also with <input type="file"> element, the button for selecting file has an english name "browse", instead of the french name "parcourir"

Summary: submit button is not translated to the locale language → submit and input file buttons are not translated to the locale language

the bug seems triggered everytime when firefox is updated to a new version in archlinux,

to fix the problem I had to go the options panel of firefox -> "languages settings" and search "french" in the options, and sometimes I had to click on the button "select alternatives" and select french

I notice that in about:config the key "intl.locale.requested" doesn't have a value, I don't know if it's normal.

Hi, unfortunately we Do not have An Arch Linux Environment, but I did try to reproduce this issue on Ubuntu 18.04 using a french Build of Firefox and I'm seeing Envoyer, instead of "Submit". I will set the component for this issue maybe one of our Devs might be able to reproduce this issue, Thanks for the Test.HTML example this will help us reproduce the issue on Arch builds.

This issue might also be related to Bug 768699.

Component: Untriaged → Localization
Product: Firefox → Core

(In reply to Barto from comment #3)

I notice that in about:config the key "intl.locale.requested" doesn't have a value, I don't know if it's normal.

That's likely the distribution adding a prefs.js with that empty value (I've seen at least a couple of them doing it).
https://bugzilla.mozilla.org/show_bug.cgi?id=1541312#c8
https://bugzilla.mozilla.org/show_bug.cgi?id=1537704#c20

I'm tempted to consider this a dupe of bug 1537704, given that we select the right language for the UI, but fail in a few other places.

The priority flag is not set for this bug.
:Pike, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(l10n)

Looking at https://git.archlinux.org/svntogit/packages.git/tree/trunk/PKGBUILD?h=packages/firefox#n120, the pref value is "", let's assume this has the same reason as bug 1537704 and dupe this.

Status: UNCONFIRMED → RESOLVED
Closed: 9 months ago
Flags: needinfo?(l10n)
Resolution: --- → DUPLICATE
Duplicate of bug: 1537704
You need to log in before you can comment on or make changes to this bug.