Closed Bug 1538184 Opened 8 months ago Closed 7 months ago

The path for Local Directory is not created in about:profiles if by creating a new profile, the user chooses where the data should be stored.

Categories

(Toolkit :: Startup and Profile System, defect)

defect
Not set

Tracking

()

RESOLVED INVALID
Tracking Status
firefox66 --- affected
firefox67 --- affected
firefox68 --- affected

People

(Reporter: oana.botisan, Unassigned)

References

Details

Affected versions

  • Firefox 68.0a1
  • Firefox 67.0b4
  • Firefox 66.0

Affected platforms

  • Windows 8.1 x64
  • Windows 7 x64
  • macOS 10.13
  • Ubuntu 18.04 x64

Steps to reproduce

  1. Open Profile Manager (terminal: "./firefox -no-remote -p")
  2. Create a new profile and click on Choose File button in order to select where you want the user data to be stored.
  3. Choose an empty folder, finish the process and open Firefox.
  4. Go to about:profiles and looked at the created profile.

Expected result

  • The profile name is displayed and underneath there are two paths: one for the Root Directory and the other for the Local Directory. The corresponding folders are created too.

Actual result

  • Only one path is created, the one for Root Directory.
  • The one for Local Directory is not displayed. The folder is not created either.

Regression range

  • I can't find the regression. I can reproduce this issue on builds from 2017-01-02.

Additional notes

  • As far as I can remember last year I couldn't reproduce this issue, I don't know why I can't seem to find a regression at the moment.

To my knowledge we've never stored the local directory in about:profiles. If IsRelative=1 in profiles.ini then the local directory is the Path relative to the local directory store. If IsRelative=0 then we just use the main profile directory as the local directory.

You can see that as far back as 2007 when we moved to mercurial we weren't writing out the local directory in profiles.ini: https://hg.mozilla.org/mozilla-central/file/9b2a99adc05e/toolkit/profile/src/nsToolkitProfileService.cpp#l795

This is the intentional behaviour.

Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.