Investigate ShutDownKill spike in builds from March 19th

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
2 months ago
a month ago

People

(Reporter: marcia, Assigned: gsvelto)

Tracking

({regression})

Trunk
Unspecified
Windows
Points:
---

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox66 unaffected, firefox67 unaffected, firefox68 fixed)

Details

Starting in https://bit.ly/2TnVXgM it appears we started a spike in ShutDownKill crashes on Nightly 68. In the last 7 days we have 14818 crashes in that signature.

Comment 1

2 months ago

could the spike in shutdownkill reports be related to the changes in bug 1533842?:
https://crash-stats.mozilla.com/signature/?product=Firefox&release_channel=nightly&signature=IPCError-browser%20%7C%20ShutDownKill&date=%3E%3D2018-09-22T17%3A08%3A00.000Z#graphs

back in november bug 1498942 had dramatically reduced the number of these reports...

Flags: needinfo?(gsvelto)

Since it is the end of the work day, adding a ni on Jim M to see if we think the bug in Comment 1 may be related.

Flags: needinfo?(jmathies)
Assignee

Comment 4

2 months ago

Yes, bug 1533842 but the issue turned out to be more complex than I had anticipated. Bug 1498942 might have had an oversized impact because it stopped minidumps from being taken when shutting down hung content processes even when it should not have to. More details in bug 1536850 comment 2. I'll have a patch ready on Monday.

Flags: needinfo?(gsvelto)
Summary: Investigate ShutDownKIll spike in builds from March 19th → Investigate ShutDownKill spike in builds from March 19th
Flags: needinfo?(jmathies)

Work ongoing in Bug 1536850.

With bug 1536850 fixed, has the investigation concluded and can we close this bug?

Flags: needinfo?(mozillamarcia.knous)
Component: General → DOM: Content Processes
Product: Firefox → Core

Would prefer to keep this open - it has only been about 3 days since that bug was fixed. We can certainly close it out when we see a little more data.

Flags: needinfo?(mozillamarcia.knous)
Assignee

Comment 8

2 months ago

As you can see the ShutDownKill crashes have measurably gone down but they've not been eliminated. This is to be expected; the issue I introduced when fixing bug 1498942 effectively eliminated taking minidumps from hung content processes so we didn't see them anymore. The remaining problem is that hung content processes have all the same signature now - as they had before - and we should probably fix that to be able to tell them apart. I'll file a bug for that.

I think we can close this one out. It would great to reference the bug Gabriele mentions in Comment 8 so we have it for future reference.

Flags: needinfo?(gsvelto)
Assignee

Comment 10

a month ago

Yes, here we go.

Flags: needinfo?(gsvelto)
See Also: → 1543113

Closing this one out per Comment 8.

Status: NEW → RESOLVED
Last Resolved: a month ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.