Last letter of search keyword sometimes does not get typed with Quantum Bar

RESOLVED DUPLICATE of bug 1538117

Status

()

defect
RESOLVED DUPLICATE of bug 1538117
4 months ago
4 months ago

People

(Reporter: agashlin, Unassigned)

Tracking

68 Branch
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox68 affected)

Details

Steps to reproduce:

  1. Set browser.urlbar.quantumbar true
  2. Set up a keyword search (for instance right click the search box on en.wikipedia.org and "Add a Keyword for this Search...")
  3. Type the keyword into the address bar

The last letter of the keyword gets highlighted in the dropdown, but it doesn't get inserted into the address bar, so when typing space next "wiki " becomes "wik " and the search therefore doesn't work.

This might depend on having a lot of stuff in the places db or cache, I haven't been able to reproduce it on a clean profile, and it doesn't happen with every keyword 100% of the time (in particular it seems to never happen with search keyword tied to a file: URL). mhowell has seen it as well, so it's not just my profile, though it might be Windows-specific. Toggling browser.urlbar.quantumbar makes it come and go.

For me this is happening 100% consistently with two of my keyword bookmarks (DXR and MSDN), but never with any of my other search keywords (which include Wikipedia). I also cannot reproduce on a fresh profile after adding those bookmarks to it.

Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1538117
You need to log in before you can comment on or make changes to this bug.