Closed Bug 1538470 Opened 7 months ago Closed 7 months ago

Crash in [@ mozilla::dom::AudioNode::AudioNode]

Categories

(Core :: Web Audio, defect, critical)

Unspecified
Windows 7
defect
Not set
critical

Tracking

()

RESOLVED FIXED
mozilla68
Tracking Status
firefox-esr60 --- unaffected
firefox66 --- unaffected
firefox67 --- unaffected
firefox68 --- fixed

People

(Reporter: calixte, Assigned: padenot)

References

(Blocks 1 open bug)

Details

(Keywords: crash, regression)

Crash Data

Attachments

(1 file)

This bug is for crash report bp-63169403-7fdf-430b-8a69-b27be0190323.

Top 7 frames of crashing thread:

0 xul.dll mozilla::dom::AudioNode::AudioNode dom/media/webaudio/AudioNode.cpp:57
1 xul.dll void mozilla::dom::AudioBufferSourceNode::AudioBufferSourceNode dom/media/webaudio/AudioBufferSourceNode.cpp:597
2 xul.dll mozilla::dom::AudioBufferSourceNode::Create dom/media/webaudio/AudioBufferSourceNode.cpp:611
3 xul.dll mozilla::dom::AudioContext::CreateBufferSource dom/media/webaudio/AudioContext.cpp:333
4 xul.dll static bool mozilla::dom::BaseAudioContext_Binding::createBufferSource dom/bindings/BaseAudioContextBinding.cpp:654
5 xul.dll mozilla::dom::binding_detail::GenericMethod<mozilla::dom::binding_detail::NormalThisPolicy, mozilla::dom::binding_detail::ThrowExceptions> dom/bindings/BindingUtils.cpp:3144
6  @0x399ab01a4d2 

There are 5 crashes (from 3 installations) in nightly 68 with buildid 20190322164604. In analyzing the backtrace, the regression may have been introduced by patch [1] to fix bug 1477205.

[1] https://hg.mozilla.org/mozilla-central/rev?node=d89b9c049fa3

Flags: needinfo?(padenot)

This is now necessary, because it's possible to effectively create new
AudioNodes on during shutdown, when the global is not available anymore.

It is unnecessary to null-check in the AudioNodeEngine methods, because they
will not run in this scenario.

This also renames the function because it can now return nullptr.

Assignee: nobody → padenot
Flags: needinfo?(padenot)
Pushed by padenot@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/58fe84489519
Null-check the global when creating AudioNodes. r=karlt
Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
See Also: → 1577184
You need to log in before you can comment on or make changes to this bug.