SVG graphics aren't rendering correctly in v66 Firefox update

VERIFIED FIXED in Firefox 66

Status

()

defect
P2
normal
VERIFIED FIXED
4 months ago
2 months ago

People

(Reporter: johnhermanstevens, Assigned: bas.schouten)

Tracking

({regression})

66 Branch
mozilla68
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(relnote-firefox 66+, firefox-esr60 unaffected, firefox66+ verified, firefox67+ verified, firefox68 verified)

Details

Attachments

(2 attachments)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/72.0.3626.121 Safari/537.36

Steps to reproduce:

Go to www.tennistv.com circular SVG graphics are rendering incorrectly on Desktop. This happens with search bar and on the menu.

Actual results:

Lines are being rendered coming off at differing angles of circular SVGs

Expected results:

Circles should be complete

Component: Untriaged → SVG
Product: Firefox → Core
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression

Regression window:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=9ac2f47b3cc21276f6d8306175a4f428dcd4378f&tochange=7eac43ea765ebb657f9749a6a8fb2c5c006fae8d

Suspect:
7eac43ea765e Bas Schouten — Bug 1519739: Attempt to create Direct2D paths on the paint thread. r=rhunt
42e89a539b98 Bas Schouten — Bug 1519760: Attempt to initialize D2D off the main thread as much as possible. r=rhunt
a7238b0eac40 Bas Schouten — Bug 1519758: Do not instruct the texture client to clear textures upon allocation on the main thread. r=rhunt

:bas.schouten, your bunch of patch seems to cause the regression.
Can you please look into this?

Blocks: 1519739
Has Regression Range: --- → yes
Has STR: --- → yes
Flags: needinfo?(bas)

[Tracking Requested - why for this release]:
New regression with 66

Filing under graphics based on regressing patch.

Component: SVG → Graphics
Priority: -- → P2

This is a dupe, but I can't find the original bug that was filed :s.

Assignee: nobody → bas
Status: NEW → ASSIGNED
Flags: needinfo?(bas)
Duplicate of this bug: 1539129
Duplicate of this bug: 1539801

Can someone make a minimal test case for this by any chance? It probably isn't hard to fix and I'll have a look, but it would probably be easier with something smaller.

(In reply to Bas Schouten (:bas.schouten) from comment #7)

Can someone make a minimal test case for this by any chance? It probably
isn't hard to fix and I'll have a look, but it would probably be easier with
something smaller.

How about using attached file attachment 9053577 [details] of Bug 1539129?

Duplicate of this bug: 1541845

(In reply to Alice0775 White from comment #8)

(In reply to Bas Schouten (:bas.schouten) from comment #7)

Can someone make a minimal test case for this by any chance? It probably
isn't hard to fix and I'll have a look, but it would probably be easier with
something smaller.

How about using attached file attachment 9053577 [details] of Bug 1539129?

Perfect, sorry, I didn't see that, thanks!

Duplicate of this bug: 1542304
Pushed by bschouten@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/950a2a101ec5
Fix typo in PathCapture::TransformedCopyToBuilder. r=rhunt
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68

Bas could you request an uplift to beta please? Thanks

Also, since we have a testcase in comment #8 let's get it verified by QA on nightly before uplifting.

Flags: qe-verify+
Flags: needinfo?(bas)

Bas, what do you think of uplifting to release for 66.0.3? Since there are several duplicate bugs filed I'm assuming many users are noticing this issue.

Ryan, can you please request uplift to beta and release? I'm waiting on this patch for 66.0.3. Thanks!

Flags: needinfo?(rhunt)

Comment on attachment 9056159 [details]
Bug 1538666: Fix typo in PathCapture::TransformedCopyToBuilder. r=rhunt

Beta/Release Uplift Approval Request

  • Feature/Bug causing the regression: Bug 1519739
  • User impact if declined: Incorrect circle drawing.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Typo fix.
  • String changes made/needed: None
Flags: needinfo?(bas)
Attachment #9056159 - Flags: approval-mozilla-release?
Attachment #9056159 - Flags: approval-mozilla-beta?

Comment on attachment 9056159 [details]
Bug 1538666: Fix typo in PathCapture::TransformedCopyToBuilder. r=rhunt

Fix for new regression in 66, looks quite safe.
Not a driver for 66.0.3 but i'm happy to include it.

Attachment #9056159 - Flags: approval-mozilla-release?
Attachment #9056159 - Flags: approval-mozilla-release+
Attachment #9056159 - Flags: approval-mozilla-beta?
Attachment #9056159 - Flags: approval-mozilla-beta+
Flags: needinfo?(rhunt)

Noted for 66.0.3 as FIXED: Circular SVG graphics now render correctly

QA Whiteboard: [qa-triaged]

Reproduced the initial issue using old affected Nightly on Windows 7 64bit.
Confirming that the issue is fixed on Firefox 66.0.3 and latest Nightly 68.0a1 on Windows 7 64bit, macOS 10.13.5 and Ubuntu 16.04 32bit (even though I did not reproduce on mac and linux platforms).

Also confirming this is fixed on Fx 67.0 across platforms (Ubuntu 16.04 32bit, Windows 10 64bit and macOS 10.13).

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.