Closed Bug 1538804 Opened 6 months ago Closed 5 months ago

Update targeting for CFR Pinned tabs to include more locales and TLDs

Categories

(Firefox :: Messaging System, enhancement, P1)

enhancement

Tracking

()

VERIFIED FIXED
Firefox 68
Iteration:
68.2 - Apr 1 - 14
Tracking Status
firefox68 --- verified

People

(Reporter: jdavis, Assigned: andreio)

References

Details

(Keywords: github-merged)

Kamyar putting together recommendation on ROW domains needed to support Pin Tabs for ROW - due 3/29.

Kamyar has confirmed via slack that we will want some custom domains to support ROW. This recommendation will likely come with what we should support now and ride the trains vs. locales we should support later once Remote Settings is live (68).

Kamyar, please add your recommendation on domains needed to support Pin Tabs for ROW by Friday, 3/29.

Thanks!

Flags: needinfo?(kardekani)
Iteration: --- → 68.2 - Apr 1 - 14
Priority: -- → P1

The following doc contains the locales that need to ride the trains. Adding more locales (that will be supported by Remote Settings) requires more user research (e.g. translated surveys). Let's revisit this again by April 14.

https://docs.google.com/document/d/1IsqZRgvmC6m5gL9NWvT6co1l2GsqsaLm9uGgDK4-Kpo/edit?usp=sharing

Flags: needinfo?(kardekani)
Assignee: nobody → andrei.br92
Summary: [CFR Pin Tabs] Domains for ROW → Update targeting for CFR Pinned tabs to include more locales and TLDs
Keywords: github-merged
Blocks: 1544126
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68

Hi Kate, I have not managed to trigger the "CFR Pin Tabs" recommendation with the latest Firefox Nightly FR locale (68.0a1 Build ID - 20190416095014) and latest Firefox Nightly DE locale builds installed, on Windows 10 x64, Arch Linux and Mac 10.13.3. However, the CFR Pin Tabs recommendation can be triggered, without any problems, using the same steps on the latest Firefox Nightly en-US locale.

In order to trigger the recommendation I've used the following steps:

  1. Navigate to any web app from the provided list.
  2. Change the system's time to 17 minutes into the future.
  3. Repeat the first two steps using the same web app.
  4. Navigate to the web app again and observe the right part of the "Address Bar".

Also, I don't know if this is the case, I've observed that the targeting parameters from the "AS Router" page are still set on "en-US" ("targeting": "locale == "en-US" && !hasPinnedTabs && recentVisits[.timestamp > (currentDate|date - 3600 * 1000 * 1)]|length >= 3",).

I'm doing something wrong, or the code has not landed on Nightly yet?

Status: RESOLVED → REOPENED
Flags: needinfo?(khudson)
Resolution: FIXED → ---

(In reply to Marius Coman [:mcoman], Experiments QA from comment #4)

Ah. So after this landed, we switched to the Remote Settings Provider (Bug 1517306).

To test this targetting, you'll have to switch back to the local provider:

Pref name - "browser.newtabpage.activity-stream.asrouter.providers.cfr"
Value - {"id":"cfr","enabled":true,"type":"local","localProvider":"CFRMessageProvider","frequency":{"custom":[{"period":"daily","cap":1}]},"categories":["cfrAddons","cfrFeatures"]}

We'll need to update the targeting in Remote Settings. I guess we can do that already because only Firefox 68 is using those.

OK, we've updated the targeting in the Remote Settings data. This bug can be verified now without changing any prefs. Thank you!

Status: REOPENED → RESOLVED
Closed: 5 months ago5 months ago
Flags: needinfo?(khudson)
Resolution: --- → FIXED

Thanks, Ricky. I have verified this issue with the latest Firefox Nightly DE (68.0a1 Build ID - 20190416220148) and Latest Firefox Nightly FR installed, on Windows 10 x64, Arch Linux and Mac 10.14.4. Now, the CFR Pin Tabs recommendation is successfully triggered on each locale.

Status: RESOLVED → VERIFIED
Component: Activity Streams: Newtab → Messaging System
You need to log in before you can comment on or make changes to this bug.