Closed Bug 1539103 Opened 9 months ago Closed 9 months ago

KeyboardInterrupt doesn't safely clean-up Raptor test job (leaves processes behind)

Categories

(Testing :: Raptor, defect, major)

Version 3
defect
Not set
major

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1506928

People

(Reporter: whimboo, Unassigned)

Details

Issuing a KeyboardInterrupt during a Raptor test doesn't kill Firefox, the Raptor script, nor the started web server, and may also leave other processes around.

After Ctl+C on MacOS I can see:

501 42633 1 0 11:27AM ttys000 0:00.56 /Users/henrik/code/gecko/obj/debug/testing/raptor-venv/bin/python /Users/henrik/code/gecko/testing/raptor/raptor/raptor.py --run-local --test raptor-webaudio --host 127.0.0.1 --binary /Users/henrik/code/gecko/obj/debug/dist/NightlyDebug.app/Contents/MacOS/firefox --app firefox --obj-path /Users/henrik/code/gecko/obj/debug --log-tbpl-level=debug
501 42638 42633 0 11:27AM ttys000 0:11.62 /Users/henrik/code/gecko/obj/debug/dist/NightlyDebug.app/Contents/MacOS/firefox -foreground -profile /var/folders/c2/q_47wqh13n902fj9_zxczclr0000gn/T/tmpNnBuUN.mozrunner

Also the web server (wptserve) as started by Raptor still accepts connections:

10:27:20 INFO - raptor-benchmark starting webserver on '127.0.0.1:52514'
10:27:20 INFO - raptor-benchmark serving benchmarks from here: /Users/henrik/code/gecko/obj/debug/testing/raptor/benchmarks

$ curl 127.0.0.1:52514
<!doctype html>
<meta name="viewport" content="width=device-width">
<title>Directory listing for /</title>
<h1>Directory listing for /</h1>

This is kinda annoying when testing locally, and stopping Raptor tests early.

Thanks Henrik, yes this is a pain, already in our queue as Bug 1506928.

Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1506928
You need to log in before you can comment on or make changes to this bug.