Perma /test_classify_by_default.html | Tracker request img-srcreceived without cookie when Gecko 68 merges to Beta on 2019-05-06

VERIFIED FIXED in Firefox 68

Status

()

defect
P1
normal
VERIFIED FIXED
4 months ago
4 months ago

People

(Reporter: RaulGurzau, Assigned: dimi)

Tracking

({regression})

unspecified
mozilla68
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox66 unaffected, firefox67 unaffected, firefox68+ verified)

Details

Attachments

(1 attachment)

[Tracking Requested - why for this release]:

Central as Beta simulation: https://treeherder.mozilla.org/#/jobs?repo=try&resultStatus=testfailed%2Cbusted%2Cexception%2Cretry%2Cusercancel%2Crunnable&revision=7badcc1ef6947dae9e04cb8b8924dbbda2593a6c&selectedJob=236116471

Log link:https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=236116471&repo=try&lineNumber=13780

Log snippet:

[task 2019-03-26T13:11:45.149Z] 13:11:45 INFO - TEST-PASS | toolkit/components/url-classifier/tests/mochitest/test_classify_by_default.html | Tracker request xmlhttprequestreceived with cookie
[task 2019-03-26T13:11:45.150Z] 13:11:45 INFO - TEST-PASS | toolkit/components/url-classifier/tests/mochitest/test_classify_by_default.html | Tracker request send-beaconreceived with cookie
[task 2019-03-26T13:11:45.150Z] 13:11:45 INFO - Buffered messages finished
[task 2019-03-26T13:11:45.152Z] 13:11:45 INFO - TEST-UNEXPECTED-FAIL | toolkit/components/url-classifier/tests/mochitest/test_classify_by_default.html | Tracker request img-srcreceived without cookie
[task 2019-03-26T13:11:45.152Z] 13:11:45 INFO - SimpleTest.ok@SimpleTest/SimpleTest.js:275:18
[task 2019-03-26T13:11:45.152Z] 13:11:45 INFO - loadTestFrame/</</<@toolkit/components/url-classifier/tests/mochitest/test_classify_by_default.html:58:11
[task 2019-03-26T13:11:45.153Z] 13:11:45 INFO - Not taking screenshot here: see the one that was previously logged
[task 2019-03-26T13:11:45.153Z] 13:11:45 INFO - TEST-UNEXPECTED-FAIL | toolkit/components/url-classifier/tests/mochitest/test_classify_by_default.html | Tracker request object-datareceived without cookie
[task 2019-03-26T13:11:45.153Z] 13:11:45 INFO - SimpleTest.ok@SimpleTest/SimpleTest.js:275:18
[task 2019-03-26T13:11:45.153Z] 13:11:45 INFO - loadTestFrame/</</<@toolkit/components/url-classifier/tests/mochitest/test_classify_by_default.html:58:11
[task 2019-03-26T13:11:45.156Z] 13:11:45 INFO - Not taking screenshot here: see the one that was previously logged
[task 2019-03-26T13:11:45.156Z] 13:11:45 INFO - TEST-UNEXPECTED-FAIL | toolkit/components/url-classifier/tests/mochitest/test_classify_by_default.html | Tracker request script-srcreceived without cookie
[task 2019-03-26T13:11:45.156Z] 13:11:45 INFO - SimpleTest.ok@SimpleTest/SimpleTest.js:275:18
[task 2019-03-26T13:11:45.157Z] 13:11:45 INFO - loadTestFrame/</</<@toolkit/components/url-classifier/tests/mochitest/test_classify_by_default.html:58:11
[task 2019-03-26T13:11:45.157Z] 13:11:45 INFO - Not taking screenshot here: see the one that was previously logged
[task 2019-03-26T13:11:45.158Z] 13:11:45 INFO - TEST-UNEXPECTED-FAIL | toolkit/components/url-classifier/tests/mochitest/test_classify_by_default.html | Tracker request iframe-srcreceived without cookie
[task 2019-03-26T13:11:45.158Z] 13:11:45 INFO - SimpleTest.ok@SimpleTest/SimpleTest.js:275:18
[task 2019-03-26T13:11:45.158Z] 13:11:45 INFO - loadTestFrame/</</<@toolkit/components/url-classifier/tests/mochitest/test_classify_by_default.html:58:11
[task 2019-03-26T13:11:45.159Z] 13:11:45 INFO - Not taking screenshot here: see the one that was previously logged

dimi, this failure seems to be from Bug 1522412, can you please take a look?

Flags: needinfo?(dlee)
Assignee: nobody → dlee
Status: NEW → ASSIGNED
Flags: needinfo?(dlee)
Priority: -- → P1

In the test_classify_by_default.html, we use "network.cookie.cookieBehavior"
to test if a channel is correctly classified.

Cookie restriction is only enabled in nightly and early beta so the
default preference is not always set. Although we set the preference
in the testcase, it is too late because that the channel's cookie
setting might inherit from it's parent and may end up with getting
the old(default) value.

In this patch, we use window.open to test the tracker frame to make
sure we use the udpated prefrence.

Pushed by dlee@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c083d75f70d4
Use window.open instead of setting iframe src in test_classify_by_default.html. ?baku r=baku
Duplicate of this bug: 1538662
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
You need to log in before you can comment on or make changes to this bug.