Closed Bug 1539468 Opened 5 months ago Closed 3 months ago

Preview can initially take awhile to populate

Categories

(DevTools :: Debugger, defect, P1)

defect

Tracking

(firefox68 fixed)

RESOLVED FIXED
Firefox 68
Tracking Status
firefox68 --- fixed

People

(Reporter: jlast, Assigned: jlast)

References

(Blocks 2 open bugs)

Details

(Keywords: helpwanted, Whiteboard: [debugger-mvp])

Attachments

(1 file)

STR:

  1. pause
  2. hover on a token

ER: should appear quickly
AR: can take multiple attempts and several seconds

NOTE: this is similar with console evaluations...

Priority: -- → P2
Keywords: helpwanted
Priority: P2 → P1
Duplicate of this bug: 1542459

Found a couple of things:

  1. sometimes selecting is true for the first hover. I think this is because clicking in the gutter is registered as a mouseDown, without a mouseUp...
  2. it looks like there is no mechanism for clearing old previews, which should definitely happen
Target Milestone: --- → Firefox 68
Blocks: dbg-perf
Assignee: nobody → jlaster
Status: NEW → ASSIGNED
Whiteboard: [debugger-mvp]
Pushed by jlaster@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f94cc66e79ec
Preview can initially take awhile to populate. r=loganfsmyth
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.