Closed Bug 1539785 Opened 2 years ago Closed 2 years ago

Delay until the correct theme is applied on startup - default theme applied first, followed by a white flash

Categories

(WebExtensions :: Themes, defect)

68 Branch
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1525762

People

(Reporter: bugzilla, Unassigned)

References

()

Details

Attachments

(1 file)

Attached video HIGQW3WSsA.mp4

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

Steps to reproduce:

Just running FF I see:

  1. White filled rectangle
  2. Black themed window
  3. Semi-themed window (light gray)
  4. Normal themed window (finally)

BTW, I use this theme: https://addons.mozilla.org/firefox/addon/simple-yet-effective/

Actual results:

Just see the video.

Expected results:

Load currently set theme and paint window controls with colors from the theme.

Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0
20190327175114

(In reply to Revertron from comment #0)

  1. White filled rectangle

I don't get this. It's probably dependent on hardware and how many tabs you have opening on startup. It might also be a Core :: Graphics issue rather than theme-related.

  1. Black themed window

I only get the default theme showing first, even if the dark theme was previously selected before switching to "Simple Yet Effective".

  1. Semi-themed window (light gray)
  2. Normal themed window (finally)

I can reproduce that. It's also not specific to the "Simple Yet Effective" theme, though it's significantly easier to reproduce with it, perhaps because of the size of the image used.

Status: UNCONFIRMED → NEW
Component: Untriaged → Themes
Ever confirmed: true
Product: Firefox → WebExtensions
Summary: Should show Firefox window using selected theme, not some defaults → Delay until the correct theme is applied on startup - default theme applied first, followed by a white flash
Version: 68 Branch → Firefox 68
  1. White filled rectangle

I don't get this. It's probably dependent on hardware and how many tabs you have opening on startup. It might also be a Core :: Graphics issue rather than theme-related.

It's probably because of the famous "early paint" or how is it named?

  1. Black themed window

I only get the default theme showing first, even if the dark theme was previously selected before switching to "Simple Yet Effective".

I haven't activated any theme before switching to "Simple Yet Effective". I've been using it for months, but only about a week ago this black madness started :)

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1525762
Version: Firefox 68 → 68 Branch
You need to log in before you can comment on or make changes to this bug.