Closed Bug 1539805 Opened 3 years ago Closed 3 years ago

Crash in [@ aticfx64.dll | AslHashFree] on old AMD drivers/hardware

Categories

(Core :: Graphics: WebRender, defect, P2)

Unspecified
Windows 10
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox67 --- unaffected
firefox68 --- fixed

People

(Reporter: marcia, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: crash, regression)

Crash Data

This bug is for crash report bp-b19255ad-748a-4c6e-b016-092a40190325.

Spotted during nightly crash triage - regression which seems to have started in 20190323214211: https://bit.ly/2TEz6h8. Not sure yet where to bucket it.

Possible regression range based on Build ID: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=2c49e736571bdcf4d8897eab3c3ad6d4a079f664&tochange=59e55930dc0f243357a8730be1a0ca372e6baddb

Top 10 frames of crashing thread:

0 aticfx64.dll aticfx64.dll@0x8619 
1 dxgi.dll AslHashFree 
2 aticfx64.dll aticfx64.dll@0x554a9 
3 ntdll.dll RtlWalkFrameChain 
4  @0x298b9ab412f 
5 d3d11.dll TCLSWrappers<CTexture2D>::CLSDestroy 
6 d3d11.dll CLayeredObjectWithCLS<CTexture2D>::Release 
7 d3d11.dll NDXGI::CDeviceChild<IDXGIResource1, IDXGISwapChainInternal>::FinalRelease 
8 d3d11.dll CLayeredObject<NDXGI::CResource>::Release 
9 d3d11.dll ATL::AtlComPtrAssign 

Component: General → Graphics

Could this be document splitting?

Component: Graphics → Graphics: WebRender
Flags: needinfo?(dothayer)
Priority: -- → P2

This is a single user crashing and was probably caused by bug 1536242 which enabled WebRender on more AMD gpus. The crashing machine was previously blocked from using WebRender.

Flags: needinfo?(dothayer)

No further crashes since the initial report. Should we close this one out?

Sure.

Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Summary: Crash in [@ aticfx64.dll | AslHashFree] → Crash in [@ aticfx64.dll | AslHashFree] on old AMD drivers/hardware
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.