Can't connect client Firefox to server Firefox using different PCs

VERIFIED FIXED in Firefox 68

Status

defect
P3
normal
VERIFIED FIXED
3 months ago
23 days ago

People

(Reporter: hani.yacoub, Assigned: ladybenko)

Tracking

(Blocks 1 bug)

68 Branch
Firefox 68
x86_64
Windows
Dependency tree / graph

Firefox Tracking Flags

(firefox68 verified, firefox69 verified)

Details

(Whiteboard: high-priority-reserve)

Attachments

(4 attachments)

Reporter

Description

3 months ago
Posted image Server FF.png

[Affected versions]:
Nightly 68.0a1

[Affected platforms]:
Platforms: Windows 10 x 64

[Steps to reproduce]:

  1. Connect Firefox Nightly using about:debugging to a server Firefox Nightly on another PC.

  2. Make sure you have 2 PC's

  3. One the first PC, open the latest Firefox Nightly(Client Firefox).

    • Enable network locations on the Client Firefox. Go to about:config and set the preferences:
      devtools.aboutdebugging.network
      devtools.aboutdebugging.new-enabled to true.
    • Open about:debugging-new on the Client Firefox. Select the "Connect" category and check that you see a text input in the Network Locations section
  4. On the second PC, start the Server Firefox
    https://gist.github.com/juliandescottes/b0d3d83154d9ea8a84db5d32aa35d2c1

  5. Connect from Client Firefox to Server Firefox:

    • On the client Firefox, go to about:debugging
    • Click on "Connect" tab and form "Via Network Location" add the IP and the port

[ Expected result]:
The connection should be made correctly.

[Actual result]:

  • The connection is not made.
  • "[ACTION FAILED] CONNECT_RUNTIME_FAILURE: Component returned failure code: 0x804b000d (NS_ERROR_CONNECTION_REFUSED) [nsIInputStream.available] error-logging.js:16:17
    onInputStreamReady@resource://devtools/shared/security/socket.js:328:16 error-logging.js:25:17" error is displayed in browser console.

[Note]:
Before trying to connect client Firefox to server Firefox, we tried to open a specific network TCP port on server machine using netcat (we used "nc -l -v localhost -p 9999" command) and telnet (IP and port)

Reporter

Updated

3 months ago
Reporter

Comment 1

3 months ago
Posted image Client FF.png
Priority: -- → P3

Ola proposed to check if she could reproduce the bug, thanks a lot!

Flags: needinfo?(ogasidlo)

Confirmed. Can't connect and getting the same error.

[ACTION FAILED] CONNECT_RUNTIME_FAILURE: Component returned failure code: 0x804b000d (NS_ERROR_CONNECTION_REFUSED) [nsIInputStream.available] error-logging.js:16:9
   errorLoggingMiddleware resource://devtools/client/aboutdebugging-new/src/middleware/error-logging.js:16 debugTargetListenerMiddleware resource://devtools/client/aboutdebugging-new/src/middleware/debug-target-listener.js:76 thunk2Redux
   connectRuntime resource://devtools/client/aboutdebugging-new/src/actions/runtimes.js:98
onInputStreamReady@resource://devtools/shared/security/socket.js:328:9
error-logging.js:25:9
   errorLoggingMiddleware resource://devtools/client/aboutdebugging-new/src/middleware/error-logging.js:25 debugTargetListenerMiddleware resource://devtools/client/aboutdebugging-new/src/middleware/debug-target-listener.js:76 thunk2Redux
   connectRuntime resource://devtools/client/aboutdebugging-new/src/actions/runtimes.js:98
Flags: needinfo?(ogasidlo)

Could you try setting "devtools.debugger.force-local" to false? I would say on the Debugger instance, but just to be safe, set it to false on both Client and Server. Thanks!

Flags: needinfo?(hani.yacoub)

OK, I made it work! :)

I set devtools.debugger.force-local to false on the server only, but I also had to make sure that devtools.debugger.remote-enabled and devtools.chrome.enabled were set to true on the server as well as starting it with the --start-debugger-server 6080 command line option as described in Julian's document.

With this I can connect to Nightly in another computer in the network. The UI is a bit weird, it first adds the runtime to the left, then you have to focus on it to get access to its debuggable objects. I haven't done extensive testing but I could see the highlighter in the inspector as I hovered over the nodes of a tab, etc, so it looks promising! :)

Setting high priority for this one, I really think we should do something. Maybe just have an info message with a link to MDN? Since we don't have an appropriate documentation page ready, we should synchronize with Irene to see if we can agree on the URL. We could link to https://developer.mozilla.org/en-US/docs/Tools/Remote_Debugging/Firefox_for_Metro#Set_up_Firefox_for_desktop in the meantime as it contains "some" relevant information.

Flags: needinfo?(hani.yacoub)
Whiteboard: high-priority-reserve
Reporter

Comment 8

2 months ago

it works for me as well after setting the prefs. Sorry for the late response.

Assignee

Updated

Last month
Assignee: nobody → balbeza
Status: NEW → ASSIGNED

Comment 10

Last month
Pushed by balbeza@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d865d7a290f8
Add help text with links to mdn in the Setup page. r=jdescottes,daisuke,Ola,Harald,flod

Comment 11

Last month
bugherder
Status: ASSIGNED → RESOLVED
Closed: Last month
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68
Reporter

Comment 12

27 days ago

What exactly should I verify in this bug? Since the links in the Setup page doesn't depend on whether Firefox is connected to another Firefox on other PC.
Thanks.

Flags: needinfo?(balbeza)

There's not much to verify I think. We just added a link to the documentation. The documentation should explain which preferences to flip in order to allow to connect to a different PC but it's not written yet.

Reporter

Comment 14

24 days ago

Verified as fixed on Firefox Nightly 69.0a1 (2019-05-27) and on Firefox 68.0b4 on Windows 10 x 64, Mac OS X 10.14 and on Ubuntu 18.04 x64 that links are added to the documentation.

Status: RESOLVED → VERIFIED
Assignee

Updated

23 days ago
Flags: needinfo?(balbeza)
You need to log in before you can comment on or make changes to this bug.