Status

defect
RESOLVED FIXED
2 months ago
2 months ago

People

(Reporter: c4609174, Unassigned)

Tracking

2016-12.6

Details

Reporter

Description

2 months ago

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Firefox/68.0

Steps to reproduce:

As it seems, I've just changed my commit mail on GitHub.

Actual results:

Auth0 deleted my account on Mozillians.

Expected results:

Nothing.

For more details and background story see: https://discourse.mozilla.org/t/auth0-creates-new-account-when-github-mail-changes/36362/6?u=rugkx

Also, I think it's generally a bad way Auth0 handles authentication. It's massively inconvenient and seems to lead to issues like this here. Plus, it is less secure than a usual mail+password login for users without LDAP.
You should not have used that. (I've explained that in details, before.)


BTW, wtf why do I have to select a version here? Who knows what runs on mozillians.org. And, especially, the latest version is something from 2016…

Hi rugk,

thanks for reaching out. I am diving into your posts and am struggling in putting all the facts together. Let me summarize:

  • You changed your primary email on GitHub
  • You were not able to login to your Mozillians.org account any longer

On Mozillians.org, I only find this profile: https://mozillians.org/u/rugk/

Can you tell me the URL of your former Mozillians.org profile?

PS: We don't address each other with "wtf" around here.

Best regards,
Henrik

Flags: needinfo?(c4609174)
Reporter

Comment 2

2 months ago

Your summary is correct. Although I was "technically" able to login again, but was presented with a "new user sign-up" form then.

PS: We don't address each other with "wtf" around here.

Yes, sorry, this whole experience is just so frustrating…

Can you tell me the URL of your former Mozillians.org profile?

Yes. The same.
As I said, it deleted my profile. The second I tried to login to Mozillians with my Auth0 it presented me a new user signup form and my old user (with the same URL) has been deleted.

You likely already saw https://github.com/mozilla/discourse/issues/176, I think it's the same issue, just on Discourse.

Flags: needinfo?(c4609174)
Reporter

Comment 3

2 months ago

BTW the account https://mozillians.org/u/rugk/ only exists because I then continued the "new user sign-up form" in the hope it would get me access to the old account in any way.

Is there actually any way to restore the old account?

Reporter

Comment 4

2 months ago

BTW, I've now recreated that account as I AFAIK had no vouches anyway, so I could fill in what may have been deleted. Anyway, this should not happen another time…

Hi rugk,

Yes, sorry, this whole experience is just so frustrating

I appreciate your comment. Thanks!

As I said, it deleted my profile. The second I tried to login to Mozillians with my Auth0 it presented me a new user signup form and my old user (with the same URL) has been deleted.

Unfortunately, it is hard to know for sure, but here's my thinking on what happened:
As your profile had not been vouched, it might have been qualified as spam by SpamAssassin. Profiles marked as spam will be auto-deleted.

As your profile is vouched now, it will not be auto-deleted any longer.

We can't recover your old account. I am sorry for this.

For future reference:
Your Mozillians.org login identity is rugk+git@<youKnowYourDomain>. Any authentication provider which returns this identity will allow you to login to your profile (FxA, Github, Google, email).

Thanks for all the details. Looks like your Mozillians.org issue is solved, so I will close this bug.

Best regards,
Henrik

Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.