Closed Bug 1540548 Opened 2 years ago Closed 2 years ago

Perma DevEdition toolkit/components/extensions/test/browser/browser_ext_management_themes.js | default disabled - Got Dark, expected Default when Gecko 68 merges to Beta on 2019-05-06

Categories

(Toolkit :: Add-ons Manager, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla68
Tracking Status
firefox-esr60 --- unaffected
firefox66 --- unaffected
firefox67 --- unaffected
firefox68 + fixed

People

(Reporter: bogdan_tara, Unassigned)

References

(Regression)

Details

[Tracking Requested - why for this release]:

Central as beta simulation:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=c37a72fa15ecb393ac1ed625fa8c18f7cd8e938f&searchStr=%28bc&selectedJob=237218593

Log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=237218433&repo=try&lineNumber=6589

[task 2019-03-31T14:11:59.267Z] 14:11:59 INFO - TEST-START | toolkit/components/extensions/test/browser/browser_ext_management_themes.js
[task 2019-03-31T14:11:59.799Z] 14:11:59 INFO - TEST-INFO | started process screentopng
[task 2019-03-31T14:12:00.442Z] 14:12:00 INFO - TEST-INFO | screentopng: exit 0
[task 2019-03-31T14:12:00.443Z] 14:12:00 INFO - Buffered messages logged at 14:11:59
[task 2019-03-31T14:12:00.443Z] 14:12:00 INFO - Entering test bound test_management_themes
[task 2019-03-31T14:12:00.444Z] 14:12:00 INFO - Extension loaded
[task 2019-03-31T14:12:00.444Z] 14:12:00 INFO - Extension loaded
[task 2019-03-31T14:12:00.444Z] 14:12:00 INFO - Simple theme test was installed
[task 2019-03-31T14:12:00.445Z] 14:12:00 INFO - TEST-PASS | toolkit/components/extensions/test/browser/browser_ext_management_themes.js | addon is theme - Expected: theme, Actual: theme -
[task 2019-03-31T14:12:00.445Z] 14:12:00 INFO - TEST-PASS | toolkit/components/extensions/test/browser/browser_ext_management_themes.js | webextension theme installed -
[task 2019-03-31T14:12:00.445Z] 14:12:00 INFO - Console message: [JavaScript Error: "Security Error: Content at chrome://browser/skin/browser.css may not load or link to moz-extension://f52e307c-cd4d-465e-8ddf-15e509b8a23e/image1.png."]
[task 2019-03-31T14:12:00.445Z] 14:12:00 INFO - Dark was disabled
[task 2019-03-31T14:12:00.445Z] 14:12:00 INFO - TEST-PASS | toolkit/components/extensions/test/browser/browser_ext_management_themes.js | addon is theme - Expected: theme, Actual: theme -
[task 2019-03-31T14:12:00.445Z] 14:12:00 INFO - Buffered messages finished
[task 2019-03-31T14:12:00.447Z] 14:12:00 INFO - TEST-UNEXPECTED-FAIL | toolkit/components/extensions/test/browser/browser_ext_management_themes.js | default disabled - Got Dark, expected Default
[task 2019-03-31T14:12:00.448Z] 14:12:00 INFO - Stack trace:
[task 2019-03-31T14:12:00.448Z] 14:12:00 INFO - chrome://mochikit/content/browser-test.js:test_is:1315
[task 2019-03-31T14:12:00.448Z] 14:12:00 INFO - chrome://mochitests/content/browser/toolkit/components/extensions/test/browser/browser_ext_management_themes.js:test_management_themes:112
[task 2019-03-31T14:12:00.449Z] 14:12:00 INFO - TEST-PASS | toolkit/components/extensions/test/browser/browser_ext_management_themes.js | got expected addons - Expected: 4, Actual: 4 -

Seems to be from https://bugzilla.mozilla.org/show_bug.cgi?id=1525762

Kris, can you please take a look?

Flags: needinfo?(kmaglione+bmo)
Blocks: 1525762
Component: General → Add-ons Manager
Product: WebExtensions → Toolkit
Summary: Perma toolkit/components/extensions/test/browser/browser_ext_management_themes.js | default disabled - Got Dark, expected Default when Gecko 68 merges to Beta on 2019-05-06 → Perma DevEdition toolkit/components/extensions/test/browser/browser_ext_management_themes.js | default disabled - Got Dark, expected Default when Gecko 68 merges to Beta on 2019-05-06
No longer blocks: 1525762
Regressed by: 1525762
Depends on: 1540856
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(kmaglione+bmo)
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
You need to log in before you can comment on or make changes to this bug.