Closed Bug 1540722 Opened 6 months ago Closed 2 months ago

Copy link location should work for learn-more links

Categories

(DevTools :: Console, enhancement, P3)

enhancement

Tracking

(firefox70 fixed)

RESOLVED FIXED
Firefox 70
Tracking Status
firefox70 --- fixed

People

(Reporter: Honza, Assigned: armando.ferreira, Mentored)

References

Details

(Keywords: good-first-bug)

Attachments

(1 file)

This is a follow up for bug 1457111

Support for coping link location from within the Console panel (through the context menu) can be extended and cover learn more links too.

Honza

Priority: -- → P3

Steps to reproduce

  1. Open the console
  2. Evaluate ff.x
  3. There should be a [Learn more] link in the output, next to the error message
  4. Right-click on it.

Expected results

I can see a Copy link location entry.

Actual results

There is no Copy link location entry.


The link is created in devtools/client/webconsole/components/Message.js#292-296, and it only misses an href attribute for the copy link location feature to work there (and maybe preventDefault on the click event).

Mentor: nchevobbe
Keywords: good-first-bug

Khyati, would you be interested working on this bug?
It's quite constrained and we know everything that needs to be done, which makes it a nice and appropriate good first bug on devtools.

Flags: needinfo?(f20160385)

(In reply to Nicolas Chevobbe from comment #2)

Khyati, would you be interested working on this bug?
It's quite constrained and we know everything that needs to be done, which makes it a nice and appropriate good first bug on devtools.

Sure. Thanks.

Flags: needinfo?(f20160385)
Assignee: nobody → f20160385
Status: NEW → ASSIGNED

Could you guide me a little about what needs to be done?

Flags: needinfo?(nchevobbe)

If you haven't already, you can read http://docs.firefox-dev.tools/getting-started/ to setup the work environment. Make sure to choose "Artifact builds" when asked, as it's much faster to work with.

Then, everything is in Comment 1 :)

Feel free to ask any question, either here or on Slack

Flags: needinfo?(nchevobbe)

Hello Khyati, is there anything blocking you on this patch? No pressure if you simply don't have the time to work on it :)

Flags: needinfo?(f20160385)

(In reply to Nicolas Chevobbe [:nchevobbe] from comment #6)

Hello Khyati, is there anything blocking you on this patch? No pressure if you simply don't have the time to work on it :)

Hi, actually I'm having exams in my college, that's why taken a break from open source. I'll continue as soon as they get over.

Khyati, is now a better time? If not, can I unassign you so other people might work on this bug? Thanks!

(In reply to Nicolas Chevobbe [:nchevobbe] from comment #8)

Khyati, is now a better time? If not, can I unassign you so other people might work on this bug? Thanks!

I'm working on it now. Sorry for the delay!

Flags: needinfo?(f20160385)

Assigning to Armando since Khyati isn't actively working on this

Assignee: f20160385 → armando.ferreira

Support for coping link location from within the Console panel (through the context menu) can be extended and cover learn more links too.

Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5d4593fb8701
Copy link location should work for learn-more links. r=nchevobbe
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70
You need to log in before you can comment on or make changes to this bug.